View Issue Details

IDProjectCategoryView StatusLast Update
0001722SkyChart1-Softwarepublic17-06-04 12:31
ReporterSasaAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinux 64-bitOSLubuntuOS Version17.04
Product Version4.1 SVN 
Target Version4.2Fixed in Version4.1 SVN 
Summary0001722: MPC - aborted download
DescriptionIf download asteroids from MPC is aborted, it will anyway start to recompute data. That is not expected behavior.
TagsNo tags attached.

Activities

Sasa

17-05-31 15:26

reporter   ~0003830

Last edited: 17-05-31 15:29

View 2 revisions

At line 3843 of pu_main.pas it is unconditionally executed re-computation. It seems it is fine instead to replace with conditional code:

  if ConfigSolsys.f_config_solsys1.autoOK then
     RecomputeAsteroid;

However, in case the latest MCP file exists and application is terminated before update is finished, there is no need to download 42MB again. That is another related scenario in which case update from existed file/archive is welcome without another download.

Patrick Chevalley

17-06-04 12:31

administrator   ~0003838

This is fixed by revision 3597 and 3598:
https://sourceforge.net/p/skychart/code/3597
https://sourceforge.net/p/skychart/code/3598

It is difficult to detect if an existing file is complete, not corrupted, and correspond to the latest available because there is no checksum available on the MPC site.

If you want to load a previously downloaded file use Setup/Solar system/Asteroid/Load MPC file/Use local file.

Issue History

Date Modified Username Field Change
17-05-30 11:10 Sasa New Issue
17-05-31 15:26 Sasa Note Added: 0003830
17-05-31 15:29 Sasa Note Edited: 0003830 View Revisions
17-06-04 12:31 Patrick Chevalley Assigned To => Patrick Chevalley
17-06-04 12:31 Patrick Chevalley Status new => resolved
17-06-04 12:31 Patrick Chevalley Resolution open => fixed
17-06-04 12:31 Patrick Chevalley Fixed in Version => 4.1 SVN
17-06-04 12:31 Patrick Chevalley Target Version => 4.2
17-06-04 12:31 Patrick Chevalley Note Added: 0003838