View Issue Details

IDProjectCategoryView StatusLast Update
0001736SkyChart1-Softwarepublic18-05-27 17:08
ReporterSasaAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version4.1 SVN 
Target Version4.2Fixed in Version4.1 SVN 
Summary0001736: Warnings after first start
DescriptionAfter installation latest unstable deb from your repository on fresh Lubuntu 64-bit installation, small warnings are shown after console start about obsolete call to RecreateWnd and destroying unallocated handle.
Steps To Reproduce$skychart
2017-07-02T10:58:37.314 Start trace
2017-07-02T10:58:37.314 Program version : 4.1-svn-3607
2017-07-02T10:58:37.314 Program compiled: 2017/06/26 05:30:37
2017-07-02T10:58:37.314 Compiler version: Lazarus 1.6.2.0 Free Pascal 3.0.0 Linux-x86_64-gtk2
2017-07-02T10:58:37.432 Screen scaling : True
2017-07-02T10:58:37.432 Screen scale : 114%
2017-07-02T10:58:37.433 Try language: en_US, en
2017-07-02T10:58:37.506 Language: en
2017-07-02T10:58:40.356 Create table cdc_ast_name ... Ok
2017-07-02T10:58:40.457 Create table cdc_ast_elem_list ... Ok
2017-07-02T10:58:40.558 Create table cdc_ast_elem ... Ok
2017-07-02T10:58:40.745 Create table cdc_ast_mag ... Ok
2017-07-02T10:58:40.854 Create table cdc_com_name ... Ok
2017-07-02T10:58:40.955 Create table cdc_com_elem_list ... Ok
2017-07-02T10:58:41.065 Create table cdc_com_elem ... Ok
2017-07-02T10:58:41.275 Create table cdc_fits ... Ok
2017-07-02T10:58:41.385 Create table cdc_country ... Ok
2017-07-02T10:58:41.697 Create table cdc_location ... Ok
2017-07-02T10:58:41.704 Connected to the SQL database ~/.skychart/database/cdc.db
WARNING: obsolete call to RecreateWnd for Tf_configobservatory
Warning: TWinControl.DestroyHandle f_configobservatory:Tf_configobservatory Handle not Allocated
2017-07-02T10:59:37.782 Scan picture directory: data/pictures/
2017-07-02T10:59:37.850 Listen on port: 3292
2017-07-02T11:01:13.473 There are 9700 catalogued images
Additional InformationNothing critical, although it can be cleaned up.
TagsNo tags attached.

Activities

Patrick Chevalley

17-07-02 11:29

administrator   ~0003872

I also get this error with 4.0 and current 4.1 every time a setup window is open. This correspond to the display of the observatory setup on the first run.

But this error is no more present with a version compiled with Lazarus 1.8 beta.
So it look like a bug with the use of frames in Lazarus 1.6 and it will be fixed as soon Lazarus 1.8 is released.

Sasa

18-02-17 08:32

reporter   ~0004455

This may be closed since Lazarus 1.8 is for a while released "stable" one revision.

Patrick Chevalley

18-05-27 17:08

administrator   ~0004771

Yes, I close this issue.

Issue History

Date Modified Username Field Change
17-07-02 11:13 Sasa New Issue
17-07-02 11:29 Patrick Chevalley Assigned To => Patrick Chevalley
17-07-02 11:29 Patrick Chevalley Status new => confirmed
17-07-02 11:29 Patrick Chevalley Target Version => 4.2
17-07-02 11:29 Patrick Chevalley Note Added: 0003872
18-02-17 08:32 Sasa Note Added: 0004455
18-05-27 17:08 Patrick Chevalley Status confirmed => resolved
18-05-27 17:08 Patrick Chevalley Resolution open => fixed
18-05-27 17:08 Patrick Chevalley Fixed in Version => 4.1 SVN
18-05-27 17:08 Patrick Chevalley Note Added: 0004771