View Issue Details

IDProjectCategoryView StatusLast Update
0001741SkyChart1-Softwarepublic17-07-16 10:27
ReporterRolf StegelmannAssigned ToPatrick Chevalley 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMac Pro (intel)OSOS-XOS Version10.12.5
Product Version4.0 
Target Version4.2Fixed in Version4.1 SVN 
Summary0001741: Interface to remote connection wINDI does not work properly.
DescriptionI installed the remote wINDI server from CloudMakers (version 2.2.6) on a Windows 7 PC with my telescope mount attached. It is a DDM85 mount that interfaces with ASCOM only. The wINDI package provides a front end to ASCOM. CnC did not connect to it. I got with CloudMakers to resolve a problem they had with the DDM85 driver they had with wINDI. I was able to use their iINDI iPad interface to drive the mount. It functions properly.

I tried to connect to wINDI again in CnC and this time it connected, with the new software version. But, the first time I tried to slew to a target it got an error message "Bad INDI Message". See attachment. I don't know whether it is CloudMakers problem or CnC's problem, but I am reporting it here as an issue. I told CLoudMakers also.
Steps To Reproduce1. bring up remote Windows ASCOM using wINDI on the remote PC.
2. set up CnC to use the remote wINDI server.
3. connect the Telescope. Pick the correct telescope driver (AstrooptikServer...)
     (it connects)
4. Slew to a target.
    gets the error "Bad INDI Message" error.
    ( the remote telescope driver never slews anywhere)
TagsNo tags attached.

Relationships

has duplicate 0001740 closed Interface to remote connection wINDI does not work properly. 

Activities

Rolf Stegelmann

17-07-04 18:36

reporter  

cndINDIissue.png (76,721 bytes)
cndINDIissue.png (76,721 bytes)

Patrick Chevalley

17-07-05 16:22

administrator   ~0003882

I see your message to Cloudmakers, at this time it not connect at all to windi with the ascom simulator.
What do you change to make it connect to windi?

I see instability when I connect to any indi server using CdC on a OS X virtual machine. But I am not sure if the problem is real or because of the VM.

I am interested if you can run the following test:

1. run indi telescope simulator on the Mac and use it from CdC. do this work?

2. install CdC for windows on the same computer as windi. connect to the ASA using indi interface in CdC to local windi server. can you slew or do you get the same error?

3. Connect to windi from the Mac and connect to the ascom simulator. can you slew the simulator?




Rolf Stegelmann

17-07-05 19:39

reporter   ~0003883

Question: “What do you change to make it connect to windi?”

1. I start up wINDI on PC (Have simulator and Astrooptik as choices)
2. start CdC
3. Telescope->Connect
     on connect window:
4. select button INDI gui
    on Gui control window I pick simulator, and connect. it connects (png gui2)
5. on connect window select button connect
    turns yellow
    then maybe 20 seconds it turns green (see connect1)
6. pick an object on CdC (i picked M101) and picked the slew option.
7. It positioned simulator to the object. (connect2) (slew1)

connect1.png (38,387 bytes)
connect1.png (38,387 bytes)

Rolf Stegelmann

17-07-05 19:40

reporter  

connect2.png (42,422 bytes)
connect2.png (42,422 bytes)

Rolf Stegelmann

17-07-05 19:41

reporter  

connect2-2.png (42,422 bytes)
connect2-2.png (42,422 bytes)

Rolf Stegelmann

17-07-05 19:41

reporter  

gui2.png (100,021 bytes)
gui2.png (100,021 bytes)

Rolf Stegelmann

17-07-05 19:42

reporter  

slew1.png (17,063 bytes)
slew1.png (17,063 bytes)

Rolf Stegelmann

17-07-05 19:51

reporter   ~0003884

Question: "I am interested if you can run the following test:

1. run indi telescope simulator on the Mac and use it from CdC. do this work?"

I am not sure what you mean by that. Remember I am new to INDI and don't know its capabilities yet.

Question: "2. install CdC for windows on the same computer as windi. connect to the ASA using indi interface in CdC to local windi server. can you slew or do you get the same error?"

I will try that later, when I have more time.

Question: "3. Connect to windi from the Mac and connect to the ascom simulator. can you slew the simulator?"

Is that not what I did in the first question? Also I did not state it, but I obviously set the IP address to the server in all of the tests as part of the test. Did that in CdC and in the INDIgui

Rolf Stegelmann

17-07-05 20:02

reporter   ~0003885

By the way this is using wINDI 2.2.6. CLoudMakers fixed some issues with it for the DDM85 mount that was not working.

Rolf Stegelmann

17-07-06 18:51

reporter   ~0003886

Last edited: 17-07-06 19:04

View 4 revisions

Question: "2. install CdC for windows on the same computer as windi. connect to the ASA using indi interface in CdC to local windi server. can you slew or do you get the same error?"

I installed CdC on the Windows computer driving the telescope. I picked ASCOM in the setup. I don't know if that is what you meant. But, the interface worked just fine. It started up the ASCOM driver for the telescope. I could select a object to slew to with no problem.

I think you wanted me to use the INDI interface.
I tried the INDI interface as I did from the Mac using the internal INDI gui. It connected.
The Telescope connect panel connected.
I tried to slew to an object and got the "Bad INDI message". The same as in image cndINDIissue.png above.

Patrick Chevalley

17-07-07 09:42

administrator   ~0003887

Thank you very much for all the testing and information.

1- I meant running indiserver on the Mac (http://www.cloudmakers.eu/indiserver/) but this is not important as 3- work for you.

2- As it do the same error on windows this is definitively something specific to the ASA driver because this windows version is well tested and work fine for me.

3- Sorry I not understand you already test this connection with the simulator.

For the next step I need to add a traffic trace option to my driver to let know why it try to process an incomplete buffer, resulting in this "bad indi message" error.

I add the information here when the CdC test version is ready, probably on Monday.

Patrick Chevalley

17-07-10 09:21

administrator   ~0003901

Last edited: 17-07-10 11:06

View 2 revisions

Today beta version skychart-4.1-3627 add a checkbox "Protocol trace" to the telescope connection dialog.

Please check this box before to connect to the ASA and try to slew to reproduce the error "bad indi message". Then close the connection.

zip and upload here the two files cdc_inditrace.log and cdc_indierror.log located in your home folder.
Note this two files are erased every time you do a new test.

Rolf Stegelmann

17-07-10 17:32

reporter   ~0003905

Ran it again with build 3637, but it did not get the 'bad indi message".

cdc_inditrace.log (2,077,088 bytes)

Rolf Stegelmann

17-07-10 17:34

reporter  

cdc_indierror.log (37 bytes)

Rolf Stegelmann

17-07-10 17:53

reporter   ~0003906

Tried it again by closing CdC and going through the process again. This time it slewed to the object (M31) but it did not get the "bad indi message". I did not upload that log yet. If you want let me know. Has same name as last one I uploaded, but different time stamp.

Slew worked. Timing issue? Trace caused the timing to change? Just a guess. someone not waiting?

Patrick Chevalley

17-07-10 18:16

administrator   ~0003907

The trace you upload is with "ScopeSim Telescope" but this one also worked with the previous version if I refer to your screenshot connect2.png.

The error was with "AstrooptikServer", can you make a trace with this one?

Rolf Stegelmann

17-07-10 19:33

reporter   ~0003909

Last edited: 17-07-10 19:38

View 2 revisions

whoops, I thought I selected it, but guess not. But my second try was with "Astroopikeerver" and it did slew and did not get the error. The scope did slew, I watched it move. The first one might have been operator error.

cdc_intierror-2.log
cdc_intitrace-2.log
connect-d

Rolf Stegelmann

17-07-10 19:34

reporter  

cdc_indierror-2.log (37 bytes)

Rolf Stegelmann

17-07-10 19:35

reporter  

cdc_inditrace-2.log (1,023,157 bytes)

Rolf Stegelmann

17-07-10 19:37

reporter  

connect-d.png (84,246 bytes)
connect-d.png (84,246 bytes)

Patrick Chevalley

17-07-16 10:27

administrator   ~0003920

In the last version I also increase the different delay and timeout a bit. Maybe this is the reason it work now.

I close the issue now but please re-open if you get the problem again.

Issue History

Date Modified Username Field Change
17-07-04 18:36 Rolf Stegelmann New Issue
17-07-04 18:36 Rolf Stegelmann File Added: cndINDIissue.png
17-07-05 16:02 Patrick Chevalley Relationship added has duplicate 0001740
17-07-05 16:22 Patrick Chevalley Assigned To => Patrick Chevalley
17-07-05 16:22 Patrick Chevalley Status new => feedback
17-07-05 16:22 Patrick Chevalley Target Version => 4.2
17-07-05 16:22 Patrick Chevalley Note Added: 0003882
17-07-05 19:39 Rolf Stegelmann File Added: connect1.png
17-07-05 19:39 Rolf Stegelmann Note Added: 0003883
17-07-05 19:39 Rolf Stegelmann Status feedback => assigned
17-07-05 19:40 Rolf Stegelmann File Added: connect2.png
17-07-05 19:41 Rolf Stegelmann File Added: connect2-2.png
17-07-05 19:41 Rolf Stegelmann File Added: gui2.png
17-07-05 19:42 Rolf Stegelmann File Added: slew1.png
17-07-05 19:51 Rolf Stegelmann Note Added: 0003884
17-07-05 20:02 Rolf Stegelmann Note Added: 0003885
17-07-06 18:51 Rolf Stegelmann Note Added: 0003886
17-07-06 19:01 Rolf Stegelmann Note Edited: 0003886 View Revisions
17-07-06 19:03 Rolf Stegelmann Note Edited: 0003886 View Revisions
17-07-06 19:04 Rolf Stegelmann Note Edited: 0003886 View Revisions
17-07-07 09:42 Patrick Chevalley Note Added: 0003887
17-07-10 09:21 Patrick Chevalley Note Added: 0003901
17-07-10 11:06 Patrick Chevalley Note Edited: 0003901 View Revisions
17-07-10 17:32 Rolf Stegelmann File Added: cdc_inditrace.log
17-07-10 17:32 Rolf Stegelmann Note Added: 0003905
17-07-10 17:34 Rolf Stegelmann File Added: cdc_indierror.log
17-07-10 17:53 Rolf Stegelmann Note Added: 0003906
17-07-10 18:16 Patrick Chevalley Note Added: 0003907
17-07-10 19:33 Rolf Stegelmann Note Added: 0003909
17-07-10 19:34 Rolf Stegelmann File Added: cdc_indierror-2.log
17-07-10 19:35 Rolf Stegelmann File Added: cdc_inditrace-2.log
17-07-10 19:37 Rolf Stegelmann File Added: connect-d.png
17-07-10 19:38 Rolf Stegelmann Note Edited: 0003909 View Revisions
17-07-16 10:27 Patrick Chevalley Status assigned => resolved
17-07-16 10:27 Patrick Chevalley Resolution open => fixed
17-07-16 10:27 Patrick Chevalley Fixed in Version => 4.1 SVN
17-07-16 10:27 Patrick Chevalley Note Added: 0003920