View Issue Details

IDProjectCategoryView StatusLast Update
0001743SkyChart1-Softwarepublic17-07-10 11:11
ReporterRolf Stegelmann Assigned ToPatrick Chevalley  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformMacOSOS-XOS Version10.12.5
Product Version4.0 
Target Version4.2Fixed in Version4.1 SVN 
Summary0001743: skychart does not respond to any input.
DescriptionThis has happened to me once before and i don't know what event causes it.

I was just playing around with the chart. The program does not respond to any mouse input. clicking on any of the tools does nothing. Clicking on a menu will drop the menu down, but it does nothing further. For example click on Observatory in the setup menu does nothing. The observatory dialog does not open. Switching away from skychart and then click on it again does redraw the menu. But that is all it does. The cursor also changes back to the target icon, from the mouse pointer. But nothing else. Right click does nothing on an object.

The keyboard arrow keys more the chart contents to a different part of the sky. It redraws the chart. The keyboard shortcuts do nothing. If I click off the skychart and then click back to the chart at some location then it does update the chart coordinates at the bottom left of the display. But if I click again in some other spot it does nothing, until I leave the skychart window and and click off screen and then come back and click on it. The menu updates when I do that also.

It is idle. It is not using any CPU time I checked that with Activity monitor. It has 4 threads. Using 308 MB.

The Quit skychart menu item is disabled. Command Q does nothing. The Doc Icon for skychart pops up and the Quit is enabled. I clicked on the Quit and the skychart dialog asking me if I want to save the settings came up. I responded yes and it quit.

I tried resizing the window. That did not work.
 
Steps To ReproduceI have no Idea. Just playing around with it, looking at different parts of the sky.
TagsNo tags attached.

Activities

Sasa

17-07-08 07:37

reporter   ~0003888

Last edited: 17-07-08 07:46

View 7 revisions

Perhaps there is "View -> Calendar" form stayed open and focus is changed to main form, then open any non-modal form (e.g. Observatory) and then change focus back to main form - application will become totally or partially unresponsive.

This is the way Lazarus handle this situation, when at least one non-modal and one modal form is open, however that is not correct way to do. Correct way is that last open modal form stay on top of open application and do not allow to be changed focus on any other related, before that modal is closed.

If unresponsive situation happens, try to see is there any application related form left open in behind and then close it first.

Only few non-modal forms I'm aware in skychart: telescope RA/DEC view, Calendar and "Solar System Information" which can be open all the time.

Patrick Chevalley

17-07-08 16:58

administrator   ~0003889

This is maybe related to this two issues : 0001642 and 0001696
The two cases are fixed in version 4.0 but maybe I miss another one, look if the problem is after opening some dialog.

The problem is when a modal form is opened from a modal form. This is specific to the Mac version and probably related to the qt4/cocoa interface.

Sasa, I not understand what you meant, in Linux the Observatory dialog is really modal and you cannot focus the main form when it is open. And non-modal form like the Calendar cannot lock the main application.

Rolf Stegelmann

17-07-08 17:32

reporter   ~0003890

Last edited: 17-07-08 17:38

View 2 revisions

I read the comments about double showmodal form in 1642. Mentioning the Observatory triggered my memory as to my changing the observatory site. Changed from Palomar to Home. I tried that again today and it hung the exact same way as it did before. So it sounds like a known problem that will be fixed in 4.2.

You don't have to use Force Quit. Just right click on the Doc Icon and click on the "Quit" option and it will terminate normal asking you if you want to save the settings.

Sasa

17-07-08 17:41

reporter   ~0003891

Last edited: 17-07-08 17:47

View 3 revisions

Patrick,

If you open non-modal form (e.g. Calendar) and then modal (Observatory), you are allowed by current Lazarus (1.6.x) to focus on main form. In that case, nothing on main form will respond.

That is how behaves in Linux (probably in Windows and Mac as well) and it is bug in Lazarus. I have attached very simple example.

1. Click on first button to open non-modal form
2. Click on second button to open modal form
3. Focus main form - it is allowed, however then nothing in main form is responsive.
4. Close then modal form and everything back to normal

test_focusing_bug.zip (130,702 bytes)

Rolf Stegelmann

17-07-08 17:59

reporter   ~0003892

Last edited: 17-07-08 18:03

View 5 revisions

That is not how it works on my Mac when I try it.

1. Click on first button to open non-modal form. (Calendar...)
     a. dialog opens.
     b. can't change focus to main window.
     c. all menu items are greyed out so I can't select them
    Therefore I can't do steps 2-4

See image modal issue.png

That's as it should work by my thinking.

modalissue .png (156,181 bytes)   
modalissue .png (156,181 bytes)   

Rolf Stegelmann

17-07-08 18:09

reporter   ~0003893

Last edited: 17-07-08 18:55

View 3 revisions

Oh, you mean using the Toolbox item calendar. Sorry, still learning.

But that is pretty normal. That would be expected. I don't see the issue here.

Sasa

17-07-08 18:31

reporter   ~0003894

Last edited: 17-07-08 18:32

View 2 revisions

Rolf,

1. Open from main menu: View -> Calendar. Or click tool bar icon "Ephemeris calendar"
2. Open from main menu: Setup -> Observatory. Or click on left tool bar icon "Observatory"

Can you focus on main windows and zoom in, search any object or anything else?

Rolf Stegelmann

17-07-08 18:54

reporter   ~0003895

Last edited: 17-07-08 18:59

View 4 revisions

I can open the "Ephemeris calendar"
   the window displays on top of the main window.

If I click main window the "Ephemeris calendar" moves to background.
I click on "Setup Observatory". The observatory dialog opens on top of the main window, covering part of it.

The calendar is behind. I can move the main window and see both of the other windows. But the calendar will always stay behind while the Observatory window is open.
 
I cannot focus on the main Window or do anything with it as long as the Observatory window is open.
Once I close it I can access the main window and the calendar window. All is as it should be.

see calobschrt.png

That all looks pretty normal to me.

calobschrt.png (262,421 bytes)   
calobschrt.png (262,421 bytes)   

Sasa

17-07-08 21:25

reporter   ~0003896

Thank you.

I think all is quite clear now.

Patrick Chevalley

17-07-09 11:13

administrator   ~0003897

Normally you can not do anything on other skychart window when the observatory setup is open. But you can do it now on the Mac because the setup forms are not modal because of bug 0001642 caused by a Qt4 bug.
As a temporary fix, waiting for Qt5 version, I replace the modal setup by a simple "on top". Source code change is here: https://sourceforge.net/p/skychart/code/3516/
Linux and Windows version are not affected by this change.

Sasa, I tested your test_focus on different system and repeat with skychart.
I can reproduce the problem only on my Lubuntu 16.04 laptop.
On Kubuntu 16.04 and 17.04 (with kde5), Fedora 26 (with gnome3) or Windows 10 it work normally, you cannot focus or do anything in the main form when the non-modal and the modal form are open and it is not possible to hide the modal form in any way.
So this bug is probably with the openbox window manager in ubuntu 16.04.

Sasa

17-07-09 11:46

reporter   ~0003898

Last edited: 17-07-09 12:14

View 4 revisions

Patrick,

Yes, I have currently Lubuntu 17.04 where this is tested.

In any event, this is not related with this issue I though it is, nor with skychart at end. Sorry for pollution. You may move or delete all unrelated notes and test archive.

Patrick Chevalley

17-07-09 14:14

administrator   ~0003899

Maybe the problem with Lubuntu need it's own issue to help other with this problem.

Rolf, about the original issue.
The next time you get the problem can you right click on the skychart dock icon and select "Show All Windows" to be sure there is not something locked in the background.

Rolf Stegelmann

17-07-09 17:14

reporter   ~0003900

The dock icon when selection "Show All Windows" only shows one window.

I can repeat the issues at will. I don't know how to edit the "Steps to reproduce the problem" or I would but it in there. This works every time:

1. start CdC
2. click on: Setup->Observatories...
3. click on: Observatory database
4. click in Observatory database dialog: OK (dialog closes)
5. click on Observatory dialog: OK (dialog closes)
6. click on main window, NO RESPONSE to click, mouse does move around.
7. on Dock icon right click then click on: Show All Windows ( only the main window shows)
8. on Dock icon right click then click on: Quit
9. Save configuration now dialog opens up: click Abort/No/Yes as appropriate.
    Cdc ends

Note: step 7 is done only to show that no other windows are open.
Steps 8-9 show how to end CdC without a Force Quit.

Patrick Chevalley

17-07-10 09:33

administrator   ~0003902

Thank you for this detailed steps.

Now I can reproduce the problem with my Sierra VM.
Strangely the problem is not present with the Yosemite VM.

Rolf Stegelmann

17-07-10 11:04

reporter   ~0003903

My OS-X Laptop is on 10.8.5 (Mountain Lion) and CdC does the same thing there as described above.

Patrick Chevalley

17-07-10 11:11

administrator   ~0003904

Maybe the difference is because my Yosemite hold the development environment?

Anyway this is fixed by revision 3627:
https://sourceforge.net/p/skychart/code/3627/

and available in today beta skychart-4.1-3627-x86_64-macosx.dmg

Please reopen this issue if you find another case.

Issue History

Date Modified Username Field Change
17-07-08 01:18 Rolf Stegelmann New Issue
17-07-08 07:37 Sasa Note Added: 0003888
17-07-08 07:39 Sasa Note Edited: 0003888 View Revisions
17-07-08 07:40 Sasa Note Edited: 0003888 View Revisions
17-07-08 07:41 Sasa Note Edited: 0003888 View Revisions
17-07-08 07:42 Sasa Note Edited: 0003888 View Revisions
17-07-08 07:45 Sasa Note Edited: 0003888 View Revisions
17-07-08 07:46 Sasa Note Edited: 0003888 View Revisions
17-07-08 16:58 Patrick Chevalley Note Added: 0003889
17-07-08 16:58 Patrick Chevalley Assigned To => Patrick Chevalley
17-07-08 16:58 Patrick Chevalley Status new => assigned
17-07-08 16:58 Patrick Chevalley Target Version => 4.2
17-07-08 17:32 Rolf Stegelmann Note Added: 0003890
17-07-08 17:38 Rolf Stegelmann Note Edited: 0003890 View Revisions
17-07-08 17:41 Sasa File Added: test_focusing_bug.zip
17-07-08 17:41 Sasa Note Added: 0003891
17-07-08 17:44 Sasa Note Edited: 0003891 View Revisions
17-07-08 17:47 Sasa Note Edited: 0003891 View Revisions
17-07-08 17:59 Rolf Stegelmann File Added: modalissue .png
17-07-08 17:59 Rolf Stegelmann Note Added: 0003892
17-07-08 18:01 Rolf Stegelmann Note Edited: 0003892 View Revisions
17-07-08 18:02 Rolf Stegelmann Note Edited: 0003892 View Revisions
17-07-08 18:02 Rolf Stegelmann Note Edited: 0003892 View Revisions
17-07-08 18:03 Rolf Stegelmann Note Edited: 0003892 View Revisions
17-07-08 18:09 Rolf Stegelmann Note Added: 0003893
17-07-08 18:14 Rolf Stegelmann Note Edited: 0003893 View Revisions
17-07-08 18:31 Sasa Note Added: 0003894
17-07-08 18:32 Sasa Note Edited: 0003894 View Revisions
17-07-08 18:54 Rolf Stegelmann File Added: calobschrt.png
17-07-08 18:54 Rolf Stegelmann Note Added: 0003895
17-07-08 18:55 Rolf Stegelmann Note Edited: 0003895 View Revisions
17-07-08 18:55 Rolf Stegelmann Note Edited: 0003893 View Revisions
17-07-08 18:56 Rolf Stegelmann Note Edited: 0003895 View Revisions
17-07-08 18:59 Rolf Stegelmann Note Edited: 0003895 View Revisions
17-07-08 21:25 Sasa Note Added: 0003896
17-07-09 11:13 Patrick Chevalley Note Added: 0003897
17-07-09 11:46 Sasa Note Added: 0003898
17-07-09 11:47 Sasa Note Edited: 0003898 View Revisions
17-07-09 11:48 Sasa Note Edited: 0003898 View Revisions
17-07-09 12:14 Sasa Note Edited: 0003898 View Revisions
17-07-09 14:14 Patrick Chevalley Note Added: 0003899
17-07-09 17:14 Rolf Stegelmann Note Added: 0003900
17-07-10 09:33 Patrick Chevalley Note Added: 0003902
17-07-10 11:04 Rolf Stegelmann Note Added: 0003903
17-07-10 11:11 Patrick Chevalley Status assigned => resolved
17-07-10 11:11 Patrick Chevalley Resolution open => fixed
17-07-10 11:11 Patrick Chevalley Fixed in Version => 4.1 SVN
17-07-10 11:11 Patrick Chevalley Note Added: 0003904