View Issue Details

IDProjectCategoryView StatusLast Update
0001847SkyChart1-Softwarepublic17-12-02 16:00
ReporterErnie ParkerAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformHP dv6z laptopOSWindowsOS VersionWin 7 64-bit
Product Version4.1 SVN 
Target Version4.2Fixed in Version4.1 SVN 
Summary0001847: Possible bug with cursor coordinates?
DescriptionWhen I use the mouse to hover over an object to determine the RA/Dec or Alt/Az coordinates (using the display in the lower left corner of CduC), as soon as the program refreshes the screen, the coordinates displayed represent the center of the screen instead of the cursor location.

Locking the screen on an object does not help. The only way to stop the above behavior is to turn off auto-refresh. While I can do that, it doesn't seem logical to me that the program would switch back to center-screen coordinates when I suspect the program still knows the location of the cursor.
Steps To Reproduce1. Have auto-refresh turned on
2. Move cursor to be centered over an object
3. Note RA/Dec/Alt/Az coordinates
4. Wait refresh to occur (I have mine set to 10 seconds)
5. Note new coordinates
TagsNo tags attached.

Activities

Ernie Parker

17-11-15 21:24

reporter  

Patrick Chevalley

17-11-15 21:49

administrator   ~0004286

Yes, this is an annoyance, but this is a feature to show the center coordinates after a refresh because the refresh can also be the result of a search.
But I can probably disable that in the case of a timer refresh.

Patrick Chevalley

17-12-02 16:00

administrator   ~0004316

This is fixed by revision 3696:
https://sourceforge.net/p/skychart/code/3696/

The change will be in Monday beta version.

Issue History

Date Modified Username Field Change
17-11-15 21:24 Ernie Parker New Issue
17-11-15 21:24 Ernie Parker File Added: CduC - Cursor Coordinates Bug.png
17-11-15 21:49 Patrick Chevalley Assigned To => Patrick Chevalley
17-11-15 21:49 Patrick Chevalley Status new => assigned
17-11-15 21:49 Patrick Chevalley Target Version => 4.2
17-11-15 21:49 Patrick Chevalley Note Added: 0004286
17-12-02 16:00 Patrick Chevalley Status assigned => resolved
17-12-02 16:00 Patrick Chevalley Resolution open => fixed
17-12-02 16:00 Patrick Chevalley Fixed in Version => 4.1 SVN
17-12-02 16:00 Patrick Chevalley Note Added: 0004316