View Issue Details

IDProjectCategoryView StatusLast Update
0001862CCdciel[All Projects] Generalpublic18-01-15 14:42
ReporterThomas JaegerAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
PlatformPCOSLinuxOS Version64bit
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001862: Autofocus Dynamic FindStarPos : Access violation
DescriptionYesterday I successfully captured some frames of NGC281 and the Maffei Galaxies. This was my second try with CCDciel, I like it.
I am quite familiar with autofocus in Sequence Generator Pro, so I decided to start with CCDciel's Dynamic Autofocus which is similar, but nothing happend. Later examinations of the log showed a Access violation. Never got CCDciel to start an curve.




Steps To Reproduce1. Focused a star manual with focus aid
2. Made a short image and select a the star again
3. Press autofocus (dynamic), nothing happend, log showed Autofocus error with Access violation
Additional InformationCannot fancy the parameter min.SNR, maybe to complicated for most of the users. Changing values here from -10 to 20 does not solve it.
TagsNo tags attached.

Activities

Thomas Jaeger

17-12-09 10:41

reporter  

log-snip.log (2,478 bytes)

Patrick Chevalley

17-12-10 15:11

administrator   ~0004342

The access violation is not the main problem because it is trapped, the important point is it cannot find and measure the star.
This message is probably because the star is too near of the frame border or because the "Star detection window size" is too big relative to the "Focus window size", both option in Preference/Focus.
Beware this two values are in unbinned pixel, so divided by two (to keep the same FOV) when using binning 2x2.
You may want to use at least 400 for "Focus window size" and 100 for "Star detection window size".

Let the min SNR to 0 for now, this disable this checking. You can set a reasonable value for your equipment later because the SNR is show in the log for every measurement.

Also this "Dynamic" method is less tested than the standard Vcurve and it is possible you get some problem. But for me it work with the Indi simulator and for now it not even started as it cannot detect the focus star.

Can you try with the increased window size as mentioned?

Thomas Jaeger

17-12-10 16:21

reporter   ~0004343

Thank you very much for the reply.
My settings were:
star detection window size =200
focus window size=400
OK I will decrese star detection window size to 100

After all, reading all documentation, I do not understand completly how CCDciel chooses a star or stars to determine focus. At my session I selected a star with doubleclick, than I have pressed autofocus.

How autofocus works with an automated sequence is also unclear to my now. I will try it later.

Patrick Chevalley

17-12-10 18:39

administrator   ~0004345

I confirm that 200/400 produce the same failure as you describe the simulator.

1/4 ratio is probably a minimum, I personally use a 1/10 ratio similar to the default value of 20/200.
I will add a check of the values ratio in the preference to avoid this problem.

For autofocus it not use the selected star, it always try to find the brightest star near the center of the image after checking it is not double.

In a sequence it first slew to the nearest star of the magnitude you select at the bottom of the autofocus options. Then return to the target after the autofocus is complete. You must have a working plate-solving setup for this to work correctly.
If you are sure the field you are imaging contain a suitable star for focusing you can avoid slewing to the focus star by checking "Stay in place for autofocus" in the sequence editor.

Thomas Jaeger

17-12-10 22:35

reporter   ~0004349

OK, what should I do? Next clear night I will use 80/400.

Thanks for your explanation in case of autofocus. I always use "stay in place" because, my mount is never connected to my pc and in my eye platesolving is too uncertain using it unattended.

For more than three years I took unattended astrophotos the whole night with great sucess. I try to minimize sources of error. Using PHD-Guiding is one of the success factors.

Patrick Chevalley

17-12-11 22:08

administrator   ~0004355

Yes 80/400 must work.
But beware this will really be 40/200 with 2x2 binning, so you must be sure it work with the highest HFD you can get. If the area is too small you can try 100/600.
It is more easy to use the manual focus to adjust this value as the star is detected the same way as for the autofocus.

There is no problem to "stay in place" for autofocus, principally if you not do narrow band imaging. Just be sure the autofocus exposure time is high enough to get a good star image.

Patrick Chevalley

17-12-12 11:15

administrator   ~0004357

Revision 742 check the focus window is at least four time the star window size.
https://sourceforge.net/p/ccdciel/code/742

Patrick Chevalley

17-12-12 16:17

administrator   ~0004358

Version 0.9.22 is available.

It add the possibility to take the mean of 3 or 5 exposure for each measurement point also for the Dynamic method.

Thomas Jaeger

17-12-26 09:59

reporter   ~0004370

I can confirm "access violation" is gone with 9.22. Thanks.
Last night dynamic method failed all the time. But it was my fault, analyzing the logs now I know that "autofocus tolerance" was too high. If it is ok for you, I will post more suggestions for autofocus operation in a separate feature request in the near future.
Issue can be closed.
Thomas

Patrick Chevalley

18-01-15 14:42

administrator   ~0004384

Thank you for your report.

Issue History

Date Modified Username Field Change
17-12-09 10:41 Thomas Jaeger New Issue
17-12-09 10:41 Thomas Jaeger File Added: screen capture 2017-12-07 17-41-43.png
17-12-09 10:41 Thomas Jaeger File Added: log-snip.log
17-12-10 15:11 Patrick Chevalley Assigned To => Patrick Chevalley
17-12-10 15:11 Patrick Chevalley Status new => feedback
17-12-10 15:11 Patrick Chevalley Note Added: 0004342
17-12-10 16:21 Thomas Jaeger File Added: Bildschirmfoto vom 2017-12-10 15-59-04.png
17-12-10 16:21 Thomas Jaeger Note Added: 0004343
17-12-10 16:21 Thomas Jaeger Status feedback => assigned
17-12-10 18:39 Patrick Chevalley Note Added: 0004345
17-12-10 22:35 Thomas Jaeger Note Added: 0004349
17-12-11 22:08 Patrick Chevalley Note Added: 0004355
17-12-12 11:15 Patrick Chevalley Note Added: 0004357
17-12-12 16:17 Patrick Chevalley Note Added: 0004358
17-12-26 09:59 Thomas Jaeger Note Added: 0004370
18-01-15 14:42 Patrick Chevalley Status assigned => resolved
18-01-15 14:42 Patrick Chevalley Resolution open => fixed
18-01-15 14:42 Patrick Chevalley Target Version => 1.0
18-01-15 14:42 Patrick Chevalley Note Added: 0004384