View Issue Details

IDProjectCategoryView StatusLast Update
0001879SkyChart1-Softwarepublic18-06-16 16:58
ReporterBatobsAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionwon't fix 
PlatformPCOSWindowsOS Version10 64bit
Product Version4.0 
Target VersionFixed in Version 
Summary0001879: LX200 mode points telescope out by up a few degrees.
DescriptionI have used version 3.10 pointing my FS2 controller as per set up (use LX200) and have never had a pointing issue. Installed version 4 and the telescope will not point accurately and randomly steers the telescope to points up to a few degrees away from the target object. The display on the screen shows the incorrect position as well. The only fix is to replace version 4 with the old version 3.10 and the issue is solved. installed the version 4 again the pointing error returned. The laptop is a new 64 bit model, but the version of sky charts I have used in the past is the 32bit version 3.10 and the version of 4 tried is the 64 bit one. I wanted the new version as the 3.10 no longer downloads comet info, the version 4 does. however the goto error is an issue.
Steps To ReproduceUninstall version 4 and replace with version 3.10. All worked. Tried again to install version 4 and pointing error returned (out by many degrees), returned to version 3.10 and all worked fine again.
TagsNo tags attached.

Activities

Patrick Chevalley

18-01-24 14:45

administrator   ~0004406

Do you not have a LX200 ASCOM driver that work with the FS2?

This internal LX200 driver is very hard to maintain for me because I no more have a compatible telescope for testing.
Also it look like the many variant of the protocol from the different manufacturer make more incompatibilities every year.

Between 3.10 and 4.0 I only apply fixes I receive from other users. Maybe some of this fix are incompatible with the FS2?

A suspect change is 2970 that change a character in the coordinate format. https://sourceforge.net/p/skychart/code/2970/
But this make the driver more compatible with the Meade documentation.

Patrick Chevalley

18-06-16 16:58

administrator   ~0004788

I remove the native lx200 driver for the next version.
Please use ASCOM or INDI instead.

Issue History

Date Modified Username Field Change
18-01-16 00:55 Batobs New Issue
18-01-24 14:45 Patrick Chevalley Assigned To => Patrick Chevalley
18-01-24 14:45 Patrick Chevalley Status new => feedback
18-01-24 14:45 Patrick Chevalley Note Added: 0004406
18-06-16 16:58 Patrick Chevalley Status feedback => resolved
18-06-16 16:58 Patrick Chevalley Resolution open => won't fix
18-06-16 16:58 Patrick Chevalley Note Added: 0004788