View Issue Details

IDProjectCategoryView StatusLast Update
0001917SkyChart1-Softwarepublic18-03-23 18:12
ReporterMichael R.Assigned To 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformPCOSWindowsOS Version10 64bit
Product Version4.0 
Target VersionFixed in Version 
Summary0001917: Server Commands ALLSKY and SETNORTH have no effect
DescriptionUsing Server commands with TCP Connection, the commands ALLSKY NORTH have no effect.

If later switching the buttons at the GUI the functions run.
Steps To ReproduceEnter the following commands using TCP Connection:

NEWCHART Test1
SELECTCHART Test1
SETOBS LAT:+51d29m44sLON:+07d25m31sALT:000mOBS:Dortmund
SETDATE "1968-04-08 14:00:00"
ALLSKY
SETNORTH
SAVEIMG PNG C:\Temp\Test1.png 0")

All commands return "OK!", but ALLSKY and SETNORTH have no effect.
Additional InformationSending commands with Visual Studio VB.NET application using TcpClient and Networkstream.
TagsALLSKY, NORTH, Server Commands, TCP

Activities

Michael R.

18-03-21 14:40

reporter   ~0004588

Sorry, seems to be my fault. it runs.

Patrick Chevalley

18-03-23 18:12

administrator   ~0004610

Many command do not have an immediate effect and you have to send REDRAW to apply them.
This is to save some processing time by not refreshing the chart after each command when you have all a sequence to send.
In your case REDRAW is to be added after SETNORTH.

Issue History

Date Modified Username Field Change
18-03-21 13:19 Michael R. New Issue
18-03-21 13:19 Michael R. Tag Attached: ALLSKY
18-03-21 13:19 Michael R. Tag Attached: NORTH
18-03-21 13:19 Michael R. Tag Attached: Server Commands
18-03-21 13:19 Michael R. Tag Attached: TCP
18-03-21 14:40 Michael R. Note Added: 0004588
18-03-23 18:12 Patrick Chevalley Status new => resolved
18-03-23 18:12 Patrick Chevalley Resolution open => no change required
18-03-23 18:12 Patrick Chevalley Note Added: 0004610