View Issue Details

IDProjectCategoryView StatusLast Update
0001925CCdciel[All Projects] Generalpublic18-04-19 17:38
ReporterThomas JaegerAssigned ToPatrick Chevalley 
PrioritylowSeveritytweakReproducibilitysometimes
Status resolvedResolutionunable to reproduce 
PlatformPCOSLinux Mint OS Version18.3
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001925: Log entry "Planetarium Error" without any error
DescriptionI made a image in 4x4bin for easy detection and framing. Sometimes I use platesolving the see were I am :-) using Skycharts.
This works really good. I like it.

Here is the log. You see, I fired platesolving two times. There is a log entry "Planetarium Error" without any real error.
Planetarium is connected, frame or image is displayed right. No Problem for me, just a notification for you.

2018-04-07T21:45:59.264 Set Binning 4x4
2018-04-07T21:45:59.265 ZWO CCD ASI183MM Pro: Set binning 4x4
2018-04-07T21:45:59.488 ZWO CCD ASI183MM Pro: Set frame type Light
2018-04-07T21:45:59.489 Start single preview
2018-04-07T21:46:03.063 End preview
2018-04-07T21:46:16.929 Start single preview
2018-04-07T21:46:19.594 End preview
2018-04-07T21:46:26.272 Start preview loop
2018-04-07T21:53:06.997 Cannot find approximate coordinates for this image.
The astrometry resolution may take a very long time.
2018-04-07T21:53:07.002 Resolving using Astrometry.Net ...
2018-04-07T21:53:13.905 Open file /home/starhopper/.config/ccdciel/tmp/ccdcielsolved.fits
2018-04-07T21:53:13.906 Astrometry.Net resolve successful.
2018-04-07T21:53:15.948 Planetarium error.
2018-04-07T21:55:01.290 Cannot find approximate coordinates for this image.
The astrometry resolution may take a very long time.
2018-04-07T21:55:01.292 Resolving using Astrometry.Net ...
2018-04-07T21:55:07.364 Open file /home/starhopper/.config/ccdciel/tmp/ccdcielsolved.fits
2018-04-07T21:55:07.365 Astrometry.Net resolve successful.
2018-04-07T21:55:09.576 Planetarium error.
2018-04-07T21:56:27.505 ZWO CCD ASI183MM Pro: Abort exposure
2018-04-07T21:56:27.506 Abort exposure
2018-04-07T21:56:27.511 Stop preview loop
TagsNo tags attached.

Activities

Patrick Chevalley

18-04-09 21:20

administrator   ~0004662

I cannot reproduce the problem. I need to add more information to this error message so we can know where it fail.

But I remark you where looping images when running the plate solving. Is it possible the solved image is replaced by a new capture before it send it to Skychart?
Can you try with a single preview, without loop, to see if it make the same error. Or to test in daytime load a saved image from a previous night.

Patrick Chevalley

18-04-09 23:05

administrator   ~0004667

The next version will show the error message from the planetarium:
https://github.com/pchev/ccdciel/commit/87109ee9c9e258770e005eb3c60868a6e715de5b

Please test when it is available.

Patrick Chevalley

18-04-10 12:00

administrator   ~0004668

The version 0.9.33 is now available
https://sourceforge.net/projects/ccdciel/files/ccdciel_0.9.33/

Thomas Jaeger

18-04-10 20:19

reporter   ~0004672

I will use this version on my next astro session. I will report the error message.

Do you mean I should not loop exposures during platesolve?

At the moment I got no image on my laptop to solve with the INDI Simulator running and looping. Cannot reproduce it. I will do this next time under the stars.

Patrick Chevalley

18-04-11 11:54

administrator   ~0004679

Normally solving with the loop must work but I never do that because this is less efficient.
After solving, the solved image is loaded to the viewer and any other action do not need to call astrometry.net again. For example you can solve and send the frame to skychart, then if you select to send the image or Sync it not has to solve again.
But if you loop the solved image is continuously replaced by a new unsolved image so every action require a call to astrometry.net.

And a possible bug here is we send the new unsolved image to skychart.
But the new version will give more information about the error.

Thomas Jaeger

18-04-16 22:32

reporter   ~0004724

I cannot reproduce "Planetarium Error" while looping exposures with the new version of ccdciel. If I got an error in the future, I will report it. This can be closed. Thanks

Patrick Chevalley

18-04-16 23:03

administrator   ~0004727

OK I close for now. Thank you for testing.

Patrick Chevalley

18-04-19 17:38

administrator   ~0004735

I think I have reproduced the problem.
The error occur when an object is selected in CdC before you send the frame or image. In this case there is some extra text send in the command response that make the comparison to fail.

This is fixed by this change:
https://github.com/pchev/ccdciel/commit/db26f15ae5bc58634ddc6842bc5a081a01cbb37d

Issue History

Date Modified Username Field Change
18-04-09 18:33 Thomas Jaeger New Issue
18-04-09 21:20 Patrick Chevalley Assigned To => Patrick Chevalley
18-04-09 21:20 Patrick Chevalley Status new => feedback
18-04-09 21:20 Patrick Chevalley Target Version => 1.0
18-04-09 21:20 Patrick Chevalley Note Added: 0004662
18-04-09 23:05 Patrick Chevalley Note Added: 0004667
18-04-10 12:00 Patrick Chevalley Note Added: 0004668
18-04-10 20:19 Thomas Jaeger Note Added: 0004672
18-04-10 20:19 Thomas Jaeger Status feedback => assigned
18-04-11 11:54 Patrick Chevalley Note Added: 0004679
18-04-16 22:32 Thomas Jaeger Note Added: 0004724
18-04-16 23:03 Patrick Chevalley Status assigned => resolved
18-04-16 23:03 Patrick Chevalley Resolution open => unable to reproduce
18-04-16 23:03 Patrick Chevalley Note Added: 0004727
18-04-19 17:38 Patrick Chevalley Note Added: 0004735