View Issue Details

IDProjectCategoryView StatusLast Update
0001942SkyChartOtherpublic18-05-27 16:39
ReporterM.RettkowitzAssigned ToPatrick Chevalley 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version8
Product Version4.1 SVN 
Target Version4.2Fixed in Version4.1 SVN 
Summary0001942: In Daemon-Mode resize has no effect
DescriptionI tried to use Skychart in daemon-mode (command line Option --daemon). Sky map shall be sized to 480 * 480 pixels. I used the startup option --resize="480 480" and also the server command RESIZE 480 480 but if saving the Image it has the size 501 * 513. The values 501 * 513 were stored in skychart.ini and also in the cdc3-files which I used. I changed the values to ChartWidth=480 ChartHeight=480, terminated and restarted Skychart.exe but this has no effect. Images were always stored with 501 * 513 Pixels.

If starting Skychart.exe without daemon option all runs well and the Image size is 480 * 480.
Steps To Reproduce- start Skychart.exe with --daemon and perhaps additional with --resize="480 480"
- load cdc3 file with server command "LOAD C:\YourPath\YourFilename.cdc3". The cdc3 file should have the entries:
  [default_chart]
  ChartWidth=480
  ChartHeight=480
- send server command "RESIZE 480 480"
- send server command "SAVEIMG PNG YourImageFileName 0"

The Image file now has the size 501 * 513 Pixels.

Try the same with startiing Skychart.exe without --daemon. Now the Image file size is 480 * 480 Pixels.
TagsDaemon, Server Commands

Activities

Patrick Chevalley

18-05-27 16:39

administrator   ~0004769

Thank you to report this problem.

The error is because it try to add the scrollbar width despite the form is not visible.
This is fixed by:
https://github.com/pchev/skychart/commit/2f0eea963a94911fc93b8a1c7f46e726da6f4253

The change will be in tomorrow beta version.

Issue History

Date Modified Username Field Change
18-05-08 09:38 M.Rettkowitz New Issue
18-05-08 09:38 M.Rettkowitz Tag Attached: Server Commands
18-05-08 09:38 M.Rettkowitz Tag Attached: Daemon
18-05-27 16:39 Patrick Chevalley Assigned To => Patrick Chevalley
18-05-27 16:39 Patrick Chevalley Status new => resolved
18-05-27 16:39 Patrick Chevalley Resolution open => fixed
18-05-27 16:39 Patrick Chevalley Fixed in Version => 4.1 SVN
18-05-27 16:39 Patrick Chevalley Target Version => 4.2
18-05-27 16:39 Patrick Chevalley Note Added: 0004769