View Issue Details

IDProjectCategoryView StatusLast Update
0001988CCdciel[All Projects] Generalpublic18-10-25 10:28
Reportertango13Assigned ToPatrick Chevalley 
PrioritylowSeverityfeatureReproducibilityN/A
Status resolvedResolutionno change required 
PlatformPCOSLinuxOS Version64bit
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0001988: Show downloaded image every n frames
DescriptionHi Patrick,
I would like to give lucky imaging a try with my CMOS camera.
However, while downloading a freshly shot image (on my Atom mini PC) takes not more than 1 second, displaying it can tale up to 5-6 seconds.
Since lucky imaging involves taking a whole lot of short exposed frames, displaying every single downloaded image could be a great waste of time.
Would it be possible and feasible to add a new option (the same as for "dither every" and "focus every") to allow to display the downloaded image every n frames?
Thank you.
TagsNo tags attached.

Activities

Patrick Chevalley

18-09-28 19:22

administrator   ~0004896

This need to be tested because there is also the time need by Indi to transfer the image to ccdciel, then the time to update the header and write the data.
For this case the best option is maybe to ask the Indi server the save the image itself, without transfer to ccdciel. Then ccdciel can read one image on N for display.
This imply the Indi server run on the same computer as ccdciel but this is probably what offer the best performance.

Patrick Chevalley

18-10-03 21:29

administrator   ~0004920

I make a first change to draw the image on screen asynchronously so the next exposure can start before the screen is redraw:
https://github.com/pchev/ccdciel/commit/a795b1a4290edce4e22546b5c90b8880b2a2bf6a

This change will be in the next version and I am interested if you can test to see if this improve the performance.

tango13

18-10-04 10:04

reporter   ~0004921

Thank you very much Patrick, I will test it as soon as I can.

tango13

18-10-05 18:49

reporter   ~0004924

Hi Patrick,
testing the new feature I don't seem to notice the asyncronicity.
Here's an excerpt from ccdciel log:

2018-10-05T18:35:25.511 2: Start capture
2018-10-05T18:35:25.512 1: Starting Light exposure 1 for 5 seconds
2018-10-05T18:35:34.474 1: Saved file /home/piero/images/Test_async/Test_async_5s_1x1_1.fits
2018-10-05T18:35:39.079 1: Starting Light exposure 2 for 5 seconds

Apart from the rather long download/save time, the second exposure starts 4.5 seconds after exposure 1 has been completed.
Also, I saw on screen that exposure 2 started right after exposure 1 had been displayed on the screen itself, which means that the behaviour seems to be the same as before.
Am I doing anything wrong?

Patrick Chevalley

18-10-23 17:03

administrator   ~0004970

Anyway I have to revert this change because it make some functions to freeze : 0001996

But I think about another option, using the Video tools to record a SER file instead of individual Fits files.
In this case this is already the Indi server that write the file independently of the preview frames send to the client. And many stacking software can use a SER file as input.

But for that your camera must support streaming.
When you open a standard Indi client do you see a Streaming tab for the camera? If this is for your ASI1600 this must be the case.

And when the camera is connected to CCDciel do you see the Video tab?
https://www.ap-i.net/ccdciel/en/documentation/video


tango13

18-10-24 10:19

reporter   ~0004971

Hi Patrick,

I did try your suggestion and indeed it seems to work on my ASI1600, I see the video tab upon connection.
I still have to understand thoroughly how the various settings work but I think it is worth a try whenever I have a chance.

If I understand correctly though, one thing (for deep sky photo, at least) could be missing in this mode and that is dithering, which normally is not needed when shooting at high frame rates the moon or planetary. Is this correct?

Thanks a lot for now for your suggestions and precious work.

Patrick Chevalley

18-10-24 22:23

administrator   ~0004975

When you shoot the moon or planet with a long focal the seeing do more than enough dithering :)

If you want to record the maximum number of image it is not possible to wait for dither.
But with the short exposure time used here, just a few seconds, the dark processing is probably sufficient. And if you not autoguide there will be probably some natural offset during the recording.

BTW for the processing AutoStakkert work fine on Linux with wine.

tango13

18-10-25 08:29

reporter   ~0004976

Thanks Patrick, at this point I think the video feature already in CCDciel and the info you gave are enough for a lucky imaging test.
Feel free to close this ticket.
Thank you.

Patrick Chevalley

18-10-25 10:28

administrator   ~0004977

OK, I close the issue.

I am interested if you can give me your impression how this video mode work for lucky imaging. Maybe it is worth to add some information in the documentation.

Issue History

Date Modified Username Field Change
18-09-26 21:29 tango13 New Issue
18-09-28 19:22 Patrick Chevalley Assigned To => Patrick Chevalley
18-09-28 19:22 Patrick Chevalley Status new => assigned
18-09-28 19:22 Patrick Chevalley Target Version => 1.0
18-09-28 19:22 Patrick Chevalley Note Added: 0004896
18-10-03 21:29 Patrick Chevalley Note Added: 0004920
18-10-04 10:04 tango13 Note Added: 0004921
18-10-05 18:49 tango13 Note Added: 0004924
18-10-23 17:03 Patrick Chevalley Status assigned => feedback
18-10-23 17:03 Patrick Chevalley Note Added: 0004970
18-10-24 10:19 tango13 Note Added: 0004971
18-10-24 10:19 tango13 Status feedback => assigned
18-10-24 22:23 Patrick Chevalley Note Added: 0004975
18-10-25 08:29 tango13 Note Added: 0004976
18-10-25 10:28 Patrick Chevalley Status assigned => resolved
18-10-25 10:28 Patrick Chevalley Resolution open => no change required
18-10-25 10:28 Patrick Chevalley Note Added: 0004977