View Issue Details

IDProjectCategoryView StatusLast Update
0002073SkyChart1-Softwarepublic19-02-04 15:29
ReporterThomas Stibor Assigned ToPatrick Chevalley  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinux AMD64OSDebian GNU/Linux buster/sid 
Product Version4.1 SVN 
Target Version4.2Fixed in Version4.1 SVN 
Summary0002073: Wrong coordinate grid and pos when changing coordinates from EQ to AZ and back to EQ (Ursa Minor)
DescriptionStarting skychart:

2019-02-04T12:07:59.185 Start trace
2019-02-04T12:07:59.185 Program version : 4.1.1-3861-c3ec43b4
2019-02-04T12:07:59.185 Program compiled: 2019/02/04 04:00:37
2019-02-04T12:07:59.185 Compiler version: Lazarus 2.0.0.3 Free Pascal 3.0.4 Linux-x86_64-gtk2
2019-02-04T12:07:59.200 Screen scaling : True
2019-02-04T12:07:59.200 Screen scale : 139%
2019-02-04T12:07:59.202 Try language: en_US, en
2019-02-04T12:07:59.204 Language: en
2019-02-04T12:08:00.518 Connected to the SQL database /home/tstibor/.skychart/database/cdc.db
2019-02-04T12:08:00.870 Listen on port: 3292

shows wrong coordinate grid and pos when changing coordinates from EQ to AZ and back to EQ (Ursa Minor)
Steps To Reproduce1.) Start skychart, set coordinate to EQ
2.) Search for polaris
3.) Set coordinate to Alt-Az
4.) Set coordinate back to EQ
TagsNo tags attached.

Activities

Thomas Stibor

19-02-04 12:14

reporter  

Patrick Chevalley

19-02-04 12:51

administrator   ~0005323

I cannot reproduce the problem.

Can you zip/tar your file ~/.skychart/skychart.ini and upload here.

Thomas Stibor

19-02-04 13:25

reporter   ~0005324

Please find attached the skychart.ini.
I can also make a short video screencast to demonstrate the problem.
skychart.ini.gz (7,326 bytes)

Patrick Chevalley

19-02-04 14:13

administrator   ~0005325

Thank you for the file.

There is wrong options for the projection in your config file, specifically a null value for EquinoxChart, this is something that must not arise.
I do more search to change the program to prevent this and fix the config in this case.

But for now you can fix it the following way:
- start the program, stay in Eq coordinates
- open the menu Setup/Chart,coordinates
- for "type of coordinates", click "Mean J2000", then immediately click back "Apparent..."
- click OK and save the configuration.

Thomas Stibor

19-02-04 14:22

reporter   ~0005326

I followed your advice and it works now, many thanks !!!
Also many thanks for providing and supporting this excellent software.

Patrick Chevalley

19-02-04 15:29

administrator   ~0005327

Good!

This change must fix the problem automatically when loading a wrong config file:
https://github.com/pchev/skychart/commit/8092df15d9653b2831596823e35e1ecb0ad672e2

Issue History

Date Modified Username Field Change
19-02-04 12:14 Thomas Stibor New Issue
19-02-04 12:14 Thomas Stibor File Added: Screenshot_2019-02-04_12-02-14.png
19-02-04 12:14 Thomas Stibor File Added: Screenshot_2019-02-04_12-01-56.png
19-02-04 12:14 Thomas Stibor File Added: Screenshot_2019-02-04_12-01-42.png
19-02-04 12:51 Patrick Chevalley Assigned To => Patrick Chevalley
19-02-04 12:51 Patrick Chevalley Status new => feedback
19-02-04 12:51 Patrick Chevalley Target Version => 4.2
19-02-04 12:51 Patrick Chevalley Note Added: 0005323
19-02-04 13:25 Thomas Stibor File Added: skychart.ini.gz
19-02-04 13:25 Thomas Stibor Note Added: 0005324
19-02-04 13:25 Thomas Stibor Status feedback => assigned
19-02-04 14:13 Patrick Chevalley Note Added: 0005325
19-02-04 14:22 Thomas Stibor Note Added: 0005326
19-02-04 15:29 Patrick Chevalley Status assigned => resolved
19-02-04 15:29 Patrick Chevalley Resolution open => fixed
19-02-04 15:29 Patrick Chevalley Fixed in Version => 4.1 SVN
19-02-04 15:29 Patrick Chevalley Note Added: 0005327