View Issue Details

IDProjectCategoryView StatusLast Update
0002085CCdciel[All Projects] Generalpublic19-02-16 20:25
ReporterhanAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.0Fixed in Version 
Summary0002085: Pixel size doesn't change in the FITS files. It only changes in the settings menu.
DescriptionAt my observatory if change the pixel size in the setting tab "camera", the value is accepted but it is not changed in the FITS files. It is always fixed at 6 micrometer. So the solver ASTAP can't solve the FITS files unless I modify the telescope focal length accordingly to compensate. The focal length is processed and reported correctly in the FITS file. The value is stored in settings xml.

Same at my office compute. The pixel size value in the FITS files is stuck at 8 micrometer. Changing isn't reported in the FITS file. Not even after restart program.

Most likely reason is that disabling check mark "pixelsize from camera driver" doesn't work.

Keywords:
XPIXSZ = 8 / [um] Pixel Size X, binned
YPIXSZ = 8 / [um] Pixel Size Y, binned




TagsNo tags attached.

Activities

han

19-02-15 23:41

reporter  

pixel settings.png (63,778 bytes)
pixel settings.png (63,778 bytes)

Patrick Chevalley

19-02-16 08:43

administrator   ~0005402

I confirm the problem. I think this option is never used because all the camera report correctly the pixel size.
I correct that later today,

Patrick Chevalley

19-02-16 19:29

administrator   ~0005405

OK I get it, actually this option do not change the FITS header that is set only with the information from the camera. But it is used to compute the pixel scale option for astrometry.net.
This is incoherent and I will change it.

Patrick Chevalley

19-02-16 20:25

administrator   ~0005406

This is fixed by
https://github.com/pchev/ccdciel/commit/ec774c44cdde7d3336001272ecfe08813189e427

Issue History

Date Modified Username Field Change
19-02-15 23:41 han New Issue
19-02-15 23:41 han File Added: pixel settings.png
19-02-16 08:43 Patrick Chevalley Note Added: 0005402
19-02-16 19:29 Patrick Chevalley Note Added: 0005405
19-02-16 20:25 Patrick Chevalley Assigned To => Patrick Chevalley
19-02-16 20:25 Patrick Chevalley Status new => resolved
19-02-16 20:25 Patrick Chevalley Resolution open => fixed
19-02-16 20:25 Patrick Chevalley Target Version => 1.0
19-02-16 20:25 Patrick Chevalley Note Added: 0005406