View Issue Details

IDProjectCategoryView StatusLast Update
0002106SkyChart1-Softwarepublic19-08-14 12:24
ReporterDonAssigned ToPatrick Chevalley 
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10 64bit
Product Version4.0 
Target Version4.2Fixed in Version4.1 SVN 
Summary0002106: Time increment increments do not work properly transitioning through 00:00:00
DescriptionThe program does not always increment the day properly when using the time increment feature (I've seen this going forwards and backwards)

I can start on 2019-03-29 23:59:55 and increment by the second, and it'll go from 2019-03-29 23:59:59 to 2019-03-29 00:00:00 to 2019-03-30 00:00:01

This does not occur if I manually enter a time of 00:00:00 and increment back and forth.

I noticed this when following a comet and was incrementing the time but it's a general issue not specific to the comets (but easiest to see that the map is showing something wrong)

Sometimes this works properly and I've stepped the time around when it works it keeps working ok, but I can usually get into the bad state by resetting the clock to system time using the check box then manually entering a time.
TagsNo tags attached.

Activities

Don

19-03-29 23:56

reporter  

Patrick Chevalley

19-03-31 18:01

administrator   ~0005530

Can you try with the last beta version 4.1, because I cannot reproduce the issue but this remember me something I fixed last year.
Download from:
https://sourceforge.net/projects/skychart/files/0-beta/2019-03-25/

Don

19-04-01 15:25

reporter   ~0005535

Yes, I can repro it on 4.1.1.

I'm running 64 bit on Windows 10 1803 if that matters.

Patrick Chevalley

19-08-14 12:24

administrator   ~0005851

This was not easy to reproduce because it depend on rounding error with the floating point calculation.

This is fixed by:
https://github.com/pchev/skychart/commit/4785a9c8802209f49f5b7819b06f402054c761c1

This will be available in the next beta version on Monday.

Issue History

Date Modified Username Field Change
19-03-29 23:56 Don New Issue
19-03-29 23:56 Don File Added: 01 Initial correct position at 19-03-29 23-23-59.png
19-03-29 23:56 Don File Added: 02 Result when incremented from 19-03-29 23-59-59 to 19-03-29 00-00-00.png
19-03-29 23:56 Don File Added: 03 Correct position for 19-03-29 00-00-00.png
19-03-31 18:01 Patrick Chevalley Assigned To => Patrick Chevalley
19-03-31 18:01 Patrick Chevalley Status new => feedback
19-03-31 18:01 Patrick Chevalley Description Updated View Revisions
19-03-31 18:01 Patrick Chevalley Note Added: 0005530
19-04-01 15:25 Don Note Added: 0005535
19-04-01 15:25 Don Status feedback => assigned
19-08-14 12:24 Patrick Chevalley Status assigned => resolved
19-08-14 12:24 Patrick Chevalley Resolution open => fixed
19-08-14 12:24 Patrick Chevalley Fixed in Version => 4.1 SVN
19-08-14 12:24 Patrick Chevalley Target Version => 4.2
19-08-14 12:24 Patrick Chevalley Note Added: 0005851