View Issue Details

IDProjectCategoryView StatusLast Update
0002149CCdciel[All Projects] Generalpublic19-07-04 17:04
ReporterThomas StiborAssigned ToPatrick Chevalley 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Platformamd64OSGNU/LinuxOS VersionDebian Buster
Product Version0.9 
Target Version1.0Fixed in Version 
Summary0002149: Version ccdciel_0.9.59-1630_amd64.deb built from master crashes at start.
DescriptionBuilding version v0.9.59-9-g8460e87 from master on

Distributor ID: Debian
Description: Debian GNU/Linux 10 (buster)
Release: 10
Codename: buster
Linux x230 4.19.0-5-amd64 #1 SMP Debian 4.19.37-5 (2019-06-19) x86_64 GNU/Linux

Results in crash when started:

tstibor@x230:~>ccdciel
TApplication.HandleException Cannot assign a TMenuItem to a TMenuItem.
  Stack trace:
  $0000000000597E9C
  $0000000000597F63
  $000000000059825B
  $0000000000430E4F
  $0000000000439044
  $00000000004418D5
TApplication.HandleException Access violation
  Stack trace:
  $000000000045F562
  $0000000000432616
  $0000000000421E9F
  $00000000005CF3DD
  $0000000000434712
  $00000000005DA458
  $00000000005CD0B1
  $00000000005CCFE1
  $0000000000437DC9
  $00000000005CB467
  $00000000005E43FC
  $00000000005E1A5E
  $000000000043206B
  $000000000043702C
  $000000000043FD2C
TWinControl.UpdateShowing.ChangeShowing failed for f_main:Tf_main, Showing reset to False
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $000000000048B566
  $000000000070E249
  $0000000000684EB3
  $00007F6D57EFF863
TApplication.HandleException: there was another exception during showing the first exception
  Stack trace:
  $000000000048B566
  $000000000070E249
  $0000000000684EB3
  $00007F6D57EFF863
[TGtk2WidgetSet.Destroy] WARNING: There are 1 unreleased GDIObjects, a detailed dump follows:
[TGtk2WidgetSet.Destroy] GDIOs: 00007F6D5426C640
[TGtk2WidgetSet.Destroy] gdiBitmap: 1
Steps To ReproduceBuild package from master with command
./buildpkg.sh
then install the build DEB package ccdciel_0.9.59-1630_amd64.deb and execute ccdciel
Tagscrash

Activities

Thomas Stibor

19-07-04 09:57

reporter  

ccdciel1.png (144,859 bytes)
ccdciel1.png (144,859 bytes)

Patrick Chevalley

19-07-04 12:28

administrator   ~0005734

Hi Thomas,

This is something I add yesterday to have the image popup menu also in the main menu so it can work using only the keyboard.

TMenuItem.Assign was added by Lazarus 2.0:
https://wiki.lazarus.freepascal.org/Lazarus_2.0.0_release_notes#Advanced_menus_Assign

For me this work with Lazarus 2.0.2 and FPC 3.0.4.
I see the Lazarus version in Buster is 2.0, so strange it not work for you. What version of Lazarus and FPC do you use?
 
Can you also try this deb compiled on my system to be sure this is not a run time problem:
https://vega.ap-i.net/tmp/ccdciel_0.9.59-1630_amd64.deb

Thomas Stibor

19-07-04 12:37

reporter   ~0005736

Hello Patrick,

your compiled deb https://vega.ap-i.net/tmp/ccdciel_0.9.59-1630_amd64.deb works on my Debian Buster without any problems.

The version I am using on Buster are:

>apt info lazarus
Package: lazarus
Version: 2.0.0+dfsg-2

and

>apt info fpc
Package: fpc
Version: 3.0.4+dfsg-22

I will try to update Lazarus to version 2.0.2 and see whether the error is gone.

Many thanks,
 Thomas

Thomas Stibor

19-07-04 12:53

reporter   ~0005737

I installed Lazarus 2.0.2 from Debian experimental repo:

>sudo apt-get -t experimental install lazarus
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  lazarus
1 upgraded, 0 newly installed, 0 to remove and 701 not upgraded.
Need to get 43.9 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://ftp.debian.org/debian experimental/main amd64 lazarus all 2.0.2+dfsg-1 [43.9 kB]
Fetched 43.9 kB in 0s (341 kB/s)
Reading changelogs... Done
(Reading database ... 611535 files and directories currently installed.)
Preparing to unpack .../lazarus_2.0.2+dfsg-1_all.deb ...
Unpacking lazarus (2.0.2+dfsg-1) over (2.0.0+dfsg-2) ...
Setting up lazarus (2.0.2+dfsg-1) ...

Recompiled ccdciel, installed the new build package ccdciel_0.9.59-1630_amd64.deb and run into the same crash.
I uploaded the DEB package + *.tar.xz to: http://stibor.net/ccdciel/

Patrick Chevalley

19-07-04 13:53

administrator   ~0005738

I installed your deb, then using:
strings /usr/bin/ccdciel |grep Lazarus
give:
Lazarus 1.8.4.0 Free Pascal 3.0.4

So you probably have another 1.8.4 version somewhere that take precedence over the 2.0.2
It is good if you can solve that, you can add the path to fpc and lazarus in parameter to buildpkg.sh

But I want the program to also work with 1.8.4 because it is still installed with many current distribution. I will make a change to replace Assign() by a copy of the required properties.

Patrick Chevalley

19-07-04 14:09

administrator   ~0005739

The commit to make it work with Lazarus 1.8:
https://github.com/pchev/ccdciel/commit/11b097d00a00367712a681b6c5edd31f3599c813

Patrick Chevalley

19-07-04 15:00

administrator   ~0005740

I totally remove this way to copy the menu and replace by static menu entries.
This is because I need to keep trace of the menuitem to maintain there status in the two menu. This is more verbose and make a bit more maintenance when the menu are changed but this is finally more simple this way and compatible with any Lazarus version.
https://github.com/pchev/ccdciel/commit/69c04e47e5970f6d5854f853ed6d722f54e6ca4f

Thomas Stibor

19-07-04 15:38

reporter   ~0005741

Many thanks, works perfectly. I also cleanup my lazarus alternative settings and now "pointing" to version:

>strings src/ccdciel | grep Lazarus
TAChartLazarusPkg
Lazarus 2.0.0.4 Free Pascal 3.0.4 Linux-x86_64-

Patrick Chevalley

19-07-04 17:04

administrator   ~0005742

Good. Thank you again to report this issue.

Issue History

Date Modified Username Field Change
19-07-04 09:57 Thomas Stibor New Issue
19-07-04 09:57 Thomas Stibor File Added: ccdciel1.png
19-07-04 09:57 Thomas Stibor Tag Attached: crash
19-07-04 12:28 Patrick Chevalley Status new => feedback
19-07-04 12:28 Patrick Chevalley Note Added: 0005734
19-07-04 12:37 Thomas Stibor Note Added: 0005736
19-07-04 12:37 Thomas Stibor Status feedback => new
19-07-04 12:53 Thomas Stibor Note Added: 0005737
19-07-04 13:53 Patrick Chevalley Note Added: 0005738
19-07-04 14:09 Patrick Chevalley Note Added: 0005739
19-07-04 15:00 Patrick Chevalley Note Added: 0005740
19-07-04 15:38 Thomas Stibor Note Added: 0005741
19-07-04 17:04 Patrick Chevalley Assigned To => Patrick Chevalley
19-07-04 17:04 Patrick Chevalley Status new => resolved
19-07-04 17:04 Patrick Chevalley Resolution open => fixed
19-07-04 17:04 Patrick Chevalley Target Version => 1.0
19-07-04 17:04 Patrick Chevalley Note Added: 0005742