View Issue Details

IDProjectCategoryView StatusLast Update
0002157SkyChart1-Softwarepublic19-08-14 10:51
ReporterrenatoAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindowsOS Version10 64bit
Product Version 
Target Version4.2Fixed in Version4.1 SVN 
Summary0002157: same star, different properties
DescriptionHi,
I noticed that on listing the objects on the current view with Object List, polaris appears 2 times on the list, once with Catalog=Star, once with catalog=TYC (Tycho 2).
What puzzles me is that the values, in particular RA,DEC and Mag does not match.
I suppose this does not happen just for Polaris. So, what's the reason? Is "TYC" catalogue more accurate than "Star" catalogue?
I have been using apparent coordinates
Steps To Reproducecenter the field of view in the NCP
include Polaris n the field
click the button Object List
sort the list by Magnitude
compare the first two entries (Polaris on Star and TYC catalogues)
Additional InformationRefer to the attached screenshot, The first two stars in the list represent Polaris.
Notice the different values for RA DE Mag
Tagsobject list

Activities

renato

19-07-21 10:39

reporter  

screenshot.png (209,434 bytes)
screenshot.png (209,434 bytes)

Patrick Chevalley

19-07-21 22:09

administrator   ~0005782

This is expected and a feature, this allow you to compare the data from different catalog.

In this case the catalog "Star" is the CdC default star catalog, at the moment "Extended Hipparcos". The position benefit of all the precision of the Hipparcos satellite main measurement.
"TYC" value is from Tycho-2 , this is from the Hipparcos star tracker data. The position is of lower precision but it as the advantage to show fainter stars.

In the case of Polaris this make a big difference for the RA number of 7s one can think it correspond to 105 arcsec, but don't forget to also multiply by cos(DEC), this give a much smaller difference of 0.9 arcsec.

The magnitude differ because the photometric passbands are not the same.

If you add more catalog to CdC , for example GAIA, you will see more different value. This is expected as GAIA give more precise position than Hipparcos.

If you not like that you can set the catalog to not overlap, use XHIP only for wide chart and use only TYC for small FOV. To make that be sure in the catalog setting the Hipparcos "min FOV" is one more than the TYC2 "max FOV".

Do this respond to your question?

renato

19-07-22 09:28

reporter   ~0005783

Hello Patrick,
yes, thank you! I would ask you a second question. After looking more deeply through the object list, I noticed that some star on the screen were not present on the Object List.
In particular if I zoom in, until a few star (less than 10 for instance) are on the screen, it is easy to notice that the object list lacks some of them.

renato

19-07-23 08:22

reporter   ~0005785

Patrick, perhaps I should open a new thread regarding this issue with the object list, because I tried again with a different catalog (Gaia DR2) an the it was even worse than with Tyco-2. Only a few of the stars visible on the screen were listed on the "object list". This Feature of CdC (object list) would be very useful to me, as I could generate and export my personal, tailor-made catalogues. Is this issue already known to you?

Patrick Chevalley

19-07-23 08:53

administrator   ~0005786

There is a limit to 100000 entry in the list, otherwise all the objects must be show.

I cannot reproduce the issue with 5-10 stars in small fov, for me all the stars are show.

Can you make a chart that show this issue, save the chart using File/Save as... , upload here with also the content of the object list you get.

renato

19-07-23 22:34

reporter   ~0005788

attached you find such a test. I zoomed in until few stars are
visible. Then I opened object list (gaiaDR2 and Hip wete active).
As you see the object list shows only 10 stars, though more were
displayed, as you see from the screenshot.
Let me know if you need more examples.

Chart_1.cdc3 (13,698 bytes)
Chart_1.png (70,650 bytes)
Chart_1.png (70,650 bytes)
testObjectList.png (207,820 bytes)
testObjectList.png (207,820 bytes)

Patrick Chevalley

19-07-25 10:12

administrator   ~0005791

Thank you for the files!

I find the error and this is corrected by:
https://github.com/pchev/skychart/commit/36c5fb802077938b797e34cfd133b5775fb6ce5f

Here is a new test version with this change so you can test.
Win32:
https://vega.ap-i.net/tmp/skychart-4.1.1-3965-windows.exe
Win64:
https://vega.ap-i.net/tmp/skychart-4.1.1-3965-windows-x64.exe

Tell me if this work as expected.

renato

19-07-27 12:14

reporter   ~0005798

Hi Patrick, the problem has disappeared!

Thank you!

Issue History

Date Modified Username Field Change
19-07-21 10:39 renato New Issue
19-07-21 10:39 renato File Added: screenshot.png
19-07-21 10:39 renato Tag Attached: object list
19-07-21 22:09 Patrick Chevalley Assigned To => Patrick Chevalley
19-07-21 22:09 Patrick Chevalley Status new => feedback
19-07-21 22:09 Patrick Chevalley Note Added: 0005782
19-07-22 09:28 renato Note Added: 0005783
19-07-22 09:28 renato Status feedback => assigned
19-07-23 08:22 renato Note Added: 0005785
19-07-23 08:53 Patrick Chevalley Status assigned => feedback
19-07-23 08:53 Patrick Chevalley Note Added: 0005786
19-07-23 22:34 renato File Added: Chart_1.cdc3
19-07-23 22:34 renato File Added: Chart_1.png
19-07-23 22:34 renato File Added: testObjectList.png
19-07-23 22:34 renato Note Added: 0005788
19-07-23 22:34 renato Status feedback => assigned
19-07-25 10:09 Patrick Chevalley Project CCdciel => SkyChart
19-07-25 10:12 Patrick Chevalley Status assigned => feedback
19-07-25 10:12 Patrick Chevalley Category General => 1-Software
19-07-25 10:12 Patrick Chevalley Target Version => 4.2
19-07-25 10:12 Patrick Chevalley Note Added: 0005791
19-07-27 12:14 renato Note Added: 0005798
19-07-27 12:14 renato Status feedback => assigned
19-08-14 10:51 Patrick Chevalley Status assigned => resolved
19-08-14 10:51 Patrick Chevalley Resolution open => fixed
19-08-14 10:51 Patrick Chevalley Fixed in Version => 4.1 SVN