View Issue Details

IDProjectCategoryView StatusLast Update
0002167SkyChart1-Softwarepublic19-08-27 20:28
ReporterRolf StegelmannAssigned ToPatrick Chevalley 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMacOSmacOSOS Version10.14.6
Product Version4.1 SVN 
Target Version4.2Fixed in Version 
Summary0002167: INDI Server not connecting completely, will not slew
DescriptionVersion 4.1.1 beta-3967-e2cbd391 2019/08/10 04:21:05

Connecting telescope via INDI to remote INDI server. It connects, but status indictor on INDI panel stays at Yellow.
It shows telescope position on chart, but I can't slew. It says slewing but it does nothing. My telescope end is doing nothing either.

My old version 4.1-svn-3700 3017/12/04 04:32:27 still works. So something is broken in the latest beta.

I can up load captured images and the trace files if needed.

TagsNo tags attached.

Activities

Patrick Chevalley

19-08-16 20:58

administrator   ~0005856

The only change that can affect the device connection since your previous version is I add the option to load the default INDI configuration.
Possibly your INDI driver do not implement the CONFIG_PROCESS property, this can make the light to stay yellow.

I make a change to not check for this property if the option to load the configuration is unchecked.
Can you install this version:
https://vega.ap-i.net/tmp/skychart-4.1.1-3976-x86_64-macosx.dmg

Then before to click Connect, be sure "Load INDI configuration" is unchecked.

Rolf Stegelmann

19-08-17 23:50

reporter   ~0005857

Last edited: 19-08-17 23:51

View 2 revisions

That change seems to make it work. I'm not sure what the "LOAD INDI Configuration" does.

As a side note the "INDI driver" panel layout has some issues. Some of the buttons are half covered. "INDI gui" and "Abort Slew" buttons. I uploaded the image.



INDI driver 2.png (147,167 bytes)
INDI driver 2.png (147,167 bytes)

Patrick Chevalley

19-08-18 14:02

administrator   ~0005858

"load Indi configuration" call the Indi method CONFIG_PROCESS.CONFIG_LOAD, this is need by driver that otherwise not reload the settings on startup.
This is the Configuration line with the Load, Save, Default button, for example here: https://www.indilib.org/images/devices/10micron/20190208_10micron-options.png
This is so common that for me every driver implement it but your driver show this is not the case.

I fixed the button overlap in MacOS, the change will be available tomorrow in the standard beta version:
https://sourceforge.net/projects/skychart/files/0-beta/

I let this issue open if you have other remarks, otherwise I close it in one week.

Rolf Stegelmann

19-08-25 10:08

reporter   ~0005871

It seems perfect now. No button overlap either.

Patrick Chevalley

19-08-27 20:28

administrator   ~0005889

Thank you for testing!

Issue History

Date Modified Username Field Change
19-08-16 19:21 Rolf Stegelmann New Issue
19-08-16 20:58 Patrick Chevalley Assigned To => Patrick Chevalley
19-08-16 20:58 Patrick Chevalley Status new => feedback
19-08-16 20:58 Patrick Chevalley Target Version => 4.2
19-08-16 20:58 Patrick Chevalley Note Added: 0005856
19-08-17 23:50 Rolf Stegelmann File Added: INDI driver 2.png
19-08-17 23:50 Rolf Stegelmann Note Added: 0005857
19-08-17 23:50 Rolf Stegelmann Status feedback => assigned
19-08-17 23:51 Rolf Stegelmann Note Edited: 0005857 View Revisions
19-08-18 14:02 Patrick Chevalley Note Added: 0005858
19-08-25 10:08 Rolf Stegelmann Note Added: 0005871
19-08-27 20:28 Patrick Chevalley Status assigned => resolved
19-08-27 20:28 Patrick Chevalley Resolution open => fixed
19-08-27 20:28 Patrick Chevalley Note Added: 0005889