View Issue Details

IDProjectCategoryView StatusLast Update
0002168SkyChart1-Softwarepublic19-08-19 09:38
ReporterhanAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version4.2Fixed in Version4.1 SVN 
Summary0002168: Major update for u_290.pas
DescriptionHello Patrick,

Attached a highly modified u_290.pas file. I modified the tile/area selection. The latest tile selection is now not only based on the center position of each tile but also on the four tile corner positions. The result is that the routine is a litter faster and it requires often less files/tiles to fill the screen. I have tested it with CDC and is fully compatible. Note however that the variable "cos_telescope_dec" is no longer global. If you add the new u_290.pas, the compiler will detect two "cos_telescope_dec" statement in cu_catalog.pas:

 u_290.cos_telescope_dec := cos(u_290.DE_290);

These two can statements be deleted. The same action is done automatically in the routine based on area290=291.

I noted that if I select a colour version of the database, the magnitude is still reported as BP rather the Johnson-V. So for a mono star database report Bp. For a colour databases report the magnitude value as Johnson-V. You could detect a colour database by defining first BP_RP in cu_catalog.pas. E.g.

Bp_Rp:=-999;

Then if you report the magnitude. if BP_RP=-999 then there is no colour database. Note that if there is a colour database selected, a star with an unknown Bp_Rp values is reported as value -128. equals Bp-Rp=-12.8

This upgrade has a low priority.

Best regards, Han
TagsNo tags attached.

Activities

han

19-08-18 22:44

reporter  

ciel magnitudes.png (34,000 bytes)
ciel magnitudes.png (34,000 bytes)
u_290.zip (10,605 bytes)

Patrick Chevalley

19-08-19 09:38

administrator   ~0005859

Hello Han,
Thank you for the update and this information about the color.

The error with the magnitude display is because at the time of the first version only g16 use V magnitude and color, so it supposed every g17 is Bp only.
I change that to test BP_RP for -999 and -128 as you suggest and it work fine, tested with g17 color and Bp.

https://github.com/pchev/skychart/commit/f711b69920f480b59e8ceabc0a185598f4c1429a

Testing with your other database I remark the deb for g16 color "g16_star_database_mag16_ colour_version.deb" available on Sourceforge miss the file g16_1801.290 , the zip is OK.

Issue History

Date Modified Username Field Change
19-08-18 22:44 han New Issue
19-08-18 22:44 han File Added: ciel magnitudes.png
19-08-18 22:44 han File Added: u_290.zip
19-08-19 09:38 Patrick Chevalley Assigned To => Patrick Chevalley
19-08-19 09:38 Patrick Chevalley Status new => resolved
19-08-19 09:38 Patrick Chevalley Resolution open => fixed
19-08-19 09:38 Patrick Chevalley Fixed in Version => 4.1 SVN
19-08-19 09:38 Patrick Chevalley Target Version => 4.2
19-08-19 09:38 Patrick Chevalley Note Added: 0005859