View Issue Details

IDProjectCategoryView StatusLast Update
0002622SkyChart1-Softwarepublic23-09-09 12:28
Reporterf6bvp@amsat.org Assigned ToPatrick Chevalley  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSLinuxOS Version64bit
Product Version4.3 beta 
Fixed in Version4.3 beta 
Summary0002622: Connect telescope and GUI menus has some fields colored in black
DescriptionThe black fields make texts unreadable.
Somehow I probably made a configuration error and now I cannot find how to recover normal menus colours.
I uninstalled and reinstalled skychart without success even after deleting home ./skycharts directory...

I tried to change Ubuntu desktop environment parameters without success either..

See joined screen capture.

Regards,

Bernard, f6bvp
Dimension Parabole
TagsNo tags attached.

Activities

f6bvp@amsat.org

23-06-21 16:33

reporter  

Patrick Chevalley

23-06-21 18:49

administrator   ~0008370

Bonjour Bernard,

Skychart do not set specific color but use the default Gtk theme color for all the elements.
I have no problem with the default Ubuntu theme so probably something was changed.

You can try the following: Open the Ubuntu Settings, for Appearance click on Dark, then back on Default. Restart Skychart and look if this change.

If this not change, install the package gtk-theme-switch: sudo apt install gtk-theme-switch
This not add a menu entry, start from a terminal: gtk-theme-switch2
Select Yaru in the list and click Apply , Yaru is the default Ubuntu theme.
Restart Skychart.

f6bvp@amsat.org

23-06-21 19:34

reporter   ~0008372

Hi Patrick,
I did install gtk-theme-switch then when I run gtk-theme-switch2 I get the following errors :
bernard@bernard-f6bvp:~/Pyindi/planet$ gtk-theme-switch2

(gtk-theme-switch2:3237): Gtk-WARNING **: 19:31:41.757: Impossible de trouver le moteur de thème dans module_path : « hcengine »
Gtk-Message: 19:31:41.758: Failed to load module "canberra-gtk-module"

(gtk-theme-switch2:3237): Gtk-WARNING **: 19:31:47.146: Impossible de trouver le moteur de thème dans module_path : « hcengine »
bernard@bernard-f6bvp:~/Pyindi/planet$

Patrick Chevalley

23-06-21 20:04

administrator   ~0008373

Strange, do you try to install a theme that require this module but it is not present? this can explain the black area in CdC.

You can install the module with: sudo apt install gtk2-engines

f6bvp@amsat.org

23-06-22 11:16

reporter   ~0008374

sudo apt install gtk2-engines
.....
Réception de :1 http://fr.archive.ubuntu.com/ubuntu kinetic/universe amd64 gtk2-engines amd64 1:2.20.2-5build2 [255 kB]
255 ko réceptionnés en 0s (2 154 ko/s)
....
However :

bernard@bernard-f6bvp:~$ sudo gtk-theme-switch2
Gtk-Message: 11:04:24.122: Failed to load module "canberra-gtk-module"

Selecting Yaru and Apply does not change anything.
In Gtk Theme Switch thee preview, clicking on button does not change anything (image).

Selecting + does not show any filename to load.



Is there any file to select

Patrick Chevalley

23-06-22 11:43

administrator   ~0008376

You must not run gtk-theme-switch2 with sudo, it is to make change for the user that run skychart.

f6bvp@amsat.org

23-06-22 12:02

reporter   ~0008377

Same error :

bernard@bernard-f6bvp:~$ gtk-theme-switch2
Gtk-Message: 12:01:18.025: Failed to load module "canberra-gtk-module"

f6bvp@amsat.org

23-06-22 12:05

reporter   ~0008378

Looking for canberra-gtk displays :

sudo find / -name canberra-gtk*
[sudo] Mot de passe de bernard :
find: ‘/run/user/1000/doc’: Permission non accordée
find: ‘/run/user/1000/gvfs’: Permission non accordée
/snap/audacity/1051/usr/lib/gnome-settings-daemon-3.0/gtk-modules/canberra-gtk-module.desktop
/snap/gnome-42-2204/105/usr/bin/canberra-gtk-play
/snap/gnome-42-2204/105/usr/lib/gnome-settings-daemon-3.0/gtk-modules/canberra-gtk-module.desktop
/snap/gnome-42-2204/105/usr/lib/gnome-settings-daemon-3.0/gtk-modules/canberra-gtk3-module.desktop
/snap/gnome-42-2204/105/usr/lib/unity-settings-daemon-1.0/gtk-modules/canberra-gtk3-module.desktop
/snap/gnome-42-2204/111/usr/bin/canberra-gtk-play
/snap/gnome-42-2204/111/usr/lib/gnome-settings-daemon-3.0/gtk-modules/canberra-gtk-module.desktop
/snap/gnome-42-2204/111/usr/lib/gnome-settings-daemon-3.0/gtk-modules/canberra-gtk3-module.desktop
/snap/gnome-42-2204/111/usr/lib/unity-settings-daemon-1.0/gtk-modules/canberra-gtk3-module.desktop
/snap/gnome-3-38-2004/140/usr/bin/canberra-gtk-play
/snap/gnome-3-38-2004/140/usr/lib/gnome-settings-daemon-3.0/gtk-modules/canberra-gtk-module.desktop
/snap/gnome-3-38-2004/137/usr/bin/canberra-gtk-play
/snap/gnome-3-38-2004/137/usr/lib/gnome-settings-daemon-3.0/gtk-modules/canberra-gtk-module.desktop
/usr/share/man/man1/canberra-gtk-play.1.gz
/usr/lib/gnome-settings-daemon-3.0/gtk-modules/canberra-gtk3-module.desktop
/usr/lib/unity-settings-daemon-1.0/gtk-modules/canberra-gtk3-module.desktop
/usr/bin/canberra-gtk-play

f6bvp@amsat.org

23-06-22 17:48

reporter   ~0008379

After googling I performed
sudo apt-get install libcanberra-gtk-module
and then could run
gtk-theme-switch2
without warning or error.
I selected Yaru Apply
and started SkyCharts.


However black menus are still there.

f6bvp@amsat.org

23-06-25 12:44

reporter   ~0008380

What background menu box color is missing ? See two screen copies.
Should I try to reinstall Gnome ? How ?

f6bvp@amsat.org

23-06-25 13:12

reporter   ~0008381

I just installed KDE desktop on same Ubuntu and all SkyChart menu boxes are perfect.

I can stay with KDE for SkyChart use.

I don't want to miss the opportunity for you to find the reason of the issue with Gnome Desktop.

If not interested I can try to reinstall Gnome ?

Regards,

Bernard

Patrick Chevalley

23-06-30 17:59

administrator   ~0008383

Bernard,

If you still have the setup with the error I am interested to see the content of the file ~/.gtkrc-2.0 in your home directory.

Before to reinstall you can try to create a new user because this will reset all the default settings for this user.

f6bvp@amsat.org

23-07-01 12:35

reporter   ~0008385

Bonjour Patrice,

Here are .gtkrc in my home directory.
I hope it has not been changed by new KDE desktop environment.

bernard@bernard-f6bvp:~$ ls -la .gtkrc*
-rw-rw-r-- 1 bernard bernard 385 juil. 1 12:25 .gtkrc-2.0
-rw-rw-r-- 1 bernard bernard 211 juin 22 17:49 .gtkrc-2.0.bak


bernard@bernard-f6bvp:~$ cat .gtkrc-2.0.bak
# -- THEME AUTO-WRITTEN BY gtk-theme-switch2 DO NOT EDIT
include "/usr/share/themes/HighContrast/gtk-2.0/gtkrc"

include "/home/bernard/.gtkrc-2.0.mine"

# -- THEME AUTO-WRITTEN BY gtk-theme-switch2 DO NOT EDIT
bernard@bernard-f6bvp:~$ cat .gtkrc-2.0
.gtkrc-2.0 .gtkrc-2.0.bak

 
bernard@bernard-f6bvp:~$ cat .gtkrc-2.0
gtk-theme-name="Breeze"
gtk-enable-animations=1
gtk-primary-button-warps-slider=0
gtk-toolbar-style=3
gtk-menu-images=1
gtk-button-images=1
gtk-cursor-theme-size=24
gtk-cursor-theme-name="breeze_cursors"
gtk-icon-theme-name="breeze-dark"
gtk-font-name="Noto Sans, 10"
# -- THEME AUTO-WRITTEN BY gtk-theme-switch2 DO NOT EDIT


# -- THEME AUTO-WRITTEN BY gtk-theme-switch2 DO NOT EDIT

f6bvp@amsat.org

23-07-01 12:40

reporter   ~0008386

Last edited: 23-07-01 12:41

Remarks :

gtkrc-2.0.bak is possibly the previous one used by Gnome ?

and there is no such file like :

include "/home/bernard/.gtkrc-2.0.mine"

Is that the possible error I experienced with Gnome desktop ?

Patrick Chevalley

23-07-01 13:49

administrator   ~0008387

OK, I reproduce the error by selecting the Highcontrast theme.
This is really an error within this theme that set a black background for some component without inverting the font color.

The current .gtkrc-2.0 with Breeze theme was set by KDE and this one work fine, this is the one I normally use on my system.

Maybe Gnome do not use this files and set it's own theme definition.
Can you open a terminal, type the following command and give me the result.
dconf dump /org/gnome/desktop/interface/

f6bvp@amsat.org

23-07-02 12:40

reporter   ~0008388

Here you are :

bernard@bernard-f6bvp:~$ dconf dump /org/gnome/desktop/interface/
[/]
color-scheme='prefer-dark'
cursor-size=24
cursor-theme='breeze_cursors'
enable-animations=true
font-name='Noto Sans, 10'
gtk-theme='Breeze'
icon-theme='breeze-dark'
locate-pointer=true
toolbar-style='text'

f6bvp@amsat.org

23-07-02 12:45

reporter   ~0008389

[gnome/terminal/legacy/profiles:/:90f2424b-d408-493e-8df7-a8b38f3f4b65]
background-color='rgb(255,255,255)'
foreground-color='rgb(0,0,0)'
palette=['rgb(23,20,33)', 'rgb(192,28,40)', 'rgb(38,162,105)', 'rgb(162,115,76)', 'rgb(18,72,139)', 'rgb(163,71,186)', 'rgb(42,161,179)', 'rgb(208,207,204)', 'rgb(94,92,100)', 'rgb(246,97,81)', 'rgb(51,209,122)', 'rgb(233,173,12)', 'rgb(42,123,222)', 'rgb(192,97,203)', 'rgb(51,199,222)', 'rgb(255,255,255)']
use-theme-colors=true
visible-name='Palette-Menu'

[gnome/terminal/legacy/profiles:/:b1dcc9dd-5262-4d8d-a863-c897e6d979b9]
audible-bell=false
background-color='rgb(255,255,221)'
bold-color-same-as-fg=true
bold-is-bright=true
cursor-blink-mode='off'
cursor-colors-set=false
foreground-color='rgb(0,0,0)'
palette=['rgb(23,20,33)', 'rgb(192,28,40)', 'rgb(38,162,105)', 'rgb(162,115,76)', 'rgb(18,72,139)', 'rgb(163,71,186)', 'rgb(42,161,179)', 'rgb(208,207,204)', 'rgb(94,92,100)', 'rgb(246,97,81)', 'rgb(51,209,122)', 'rgb(233,173,12)', 'rgb(42,123,222)', 'rgb(192,97,203)', 'rgb(51,199,222)', 'rgb(255,255,255)']
use-theme-colors=false
use-theme-transparency=false
use-transparent-background=false

[gnome/terminal/legacy/profiles:/:c1b5497e-6579-4ea5-8243-0aa966711306]
audible-bell=false
background-color='rgb(255,255,221)'
bold-color-same-as-fg=true
bold-is-bright=false
cursor-blink-mode='off'
cursor-colors-set=false
foreground-color='rgb(0,0,0)'
palette=['rgb(23,20,33)', 'rgb(192,28,40)', 'rgb(38,162,105)', 'rgb(162,115,76)', 'rgb(18,72,139)', 'rgb(163,71,186)', 'rgb(42,161,179)', 'rgb(208,207,204)', 'rgb(94,92,100)', 'rgb(246,97,81)', 'rgb(51,209,122)', 'rgb(233,173,12)', 'rgb(42,123,222)', 'rgb(192,97,203)', 'rgb(51,199,222)', 'rgb(255,255,255)']
use-theme-colors=true
use-theme-transparency=false
use-transparent-background=false
visible-name='Défaut'

[gnome/yelp]
show-cursor=true

Patrick Chevalley

23-09-09 12:28

administrator   ~0008545

Fixed by compiling new version of CdC for Qt5 instead of GTK2.

Issue History

Date Modified Username Field Change
23-06-21 16:33 f6bvp@amsat.org New Issue
23-06-21 16:33 f6bvp@amsat.org File Added: Capture d’écran du 2023-06-21 16-07-34.png
23-06-21 18:49 Patrick Chevalley Status new => feedback
23-06-21 18:49 Patrick Chevalley Note Added: 0008370
23-06-21 19:34 f6bvp@amsat.org Note Added: 0008372
23-06-21 19:34 f6bvp@amsat.org Status feedback => new
23-06-21 20:04 Patrick Chevalley Note Added: 0008373
23-06-22 11:16 f6bvp@amsat.org Note Added: 0008374
23-06-22 11:16 f6bvp@amsat.org File Added: Capture d’écran du 2023-06-22 11-14-05.png
23-06-22 11:16 f6bvp@amsat.org File Added: Capture d’écran du 2023-06-22 11-15-58.png
23-06-22 11:43 Patrick Chevalley Note Added: 0008376
23-06-22 12:02 f6bvp@amsat.org Note Added: 0008377
23-06-22 12:05 f6bvp@amsat.org Note Added: 0008378
23-06-22 17:48 f6bvp@amsat.org Note Added: 0008379
23-06-25 12:44 f6bvp@amsat.org Note Added: 0008380
23-06-25 12:44 f6bvp@amsat.org File Added: Capture d’écran du 2023-06-25 12-23-51.png
23-06-25 12:44 f6bvp@amsat.org File Added: Capture d’écran du 2023-06-25 12-24-14.png
23-06-25 13:12 f6bvp@amsat.org Note Added: 0008381
23-06-30 17:59 Patrick Chevalley Note Added: 0008383
23-07-01 12:35 f6bvp@amsat.org Note Added: 0008385
23-07-01 12:40 f6bvp@amsat.org Note Added: 0008386
23-07-01 12:41 f6bvp@amsat.org Note Edited: 0008386
23-07-01 13:49 Patrick Chevalley Note Added: 0008387
23-07-02 12:40 f6bvp@amsat.org Note Added: 0008388
23-07-02 12:45 f6bvp@amsat.org Note Added: 0008389
23-09-09 12:28 Patrick Chevalley Assigned To => Patrick Chevalley
23-09-09 12:28 Patrick Chevalley Status new => resolved
23-09-09 12:28 Patrick Chevalley Resolution open => fixed
23-09-09 12:28 Patrick Chevalley Fixed in Version => 4.3 beta
23-09-09 12:28 Patrick Chevalley Note Added: 0008545