View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001109SkyChart1-Softwarepublic13-01-05 14:2713-05-06 14:32
Reporteraruangra 
Assigned ToPatrick Chevalley 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformARMOSUbuntu ARMHFOS Version12.10
Product Version3.7 SVN 
Target Version3.8Fixed in Version3.7 SVN 
Summary0001109: Wrong planet coordinate
DescriptionI got the wrong coordinate of planets
http://imageshack.us/a/img152/4357/planetah.jpg [^]

And there is always an error message
2013-01-05T12:36:09.567 Ephemeris probably out of range, disabling any solar system object
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0002394)
aruangra (reporter)
13-01-05 14:32

Correction: Subject is "Wrong planet coordinate"

After removing the file /usr/local/share/skychart/data/jpleph/unxp2000.405, I get the access violation error.

root@rk3066dev:/usr/local/share/skychart/data/jpleph# skychart
2013-01-05T13:15:19.829 Start trace
2013-01-05T13:15:19.835 Try language: en_US, en
2013-01-05T13:15:19.847 Language: en English
2013-01-05T13:15:22.651 Connected to the SQL database /root/.skychart
2013-01-05T13:15:26.588 Initialization error: Access violation
TApplication.HandleException Access violation
  Stack trace:
  $40EE2FFA
root@rk3066dev:/usr/local/share/skychart/data/jpleph#
(0002396)
Patrick Chevalley (administrator)
13-01-05 16:02

When you search for Saturn and the planet are not active it find the Saturn nebulae = ngc7009.
Your screenshot show a bug with the coordinates that are set to 0 in this case.
This problem is fixed by http://sourceforge.net/p/skychart/code/2363 [^]

Can you run skychart with the verbose option when you get the access violation.
(0002399)
aruangra (reporter)
13-01-06 00:35
edited on: 13-01-06 00:39

This is what happens after removing unxp2000.405
I am on SVN 2360.

root@rk3066dev:~# rm /usr/local/share/skychart/data/jplep/unxp2000.405
root@rk3066dev:~# skychart --verbose
Application directory
appdir=/usr/local/bin/
appdir=/usr/local/share/skychart
appdir=/usr/local/share/skychart
privatedir=/root/.skychart
ZoneDir=/usr/local/share/skychart/data/zoneinfo/
Try /usr/share/zoneinfo/
ZoneDir=/usr/share/zoneinfo/
Trace
2013-01-05T13:45:54.503 Start trace
2013-01-05T13:45:54.503 Privatedir: /root/.skychart
2013-01-05T13:45:54.503 Appdir: /usr/local/share/skychart
2013-01-05T13:45:54.503 Language
2013-01-05T13:45:54.508 Try language: en_US, en
2013-01-05T13:45:54.519 Language: en English
2013-01-05T13:45:54.521 Multiframe
2013-01-05T13:45:54.586 Size control
2013-01-05T13:45:54.587 Load zlib
2013-01-05T13:45:54.587 Load plan404
2013-01-05T13:45:54.589 Load cdcwcs
2013-01-05T13:45:54.592 Multiframe unix
2013-01-05T13:45:54.593 Bitmap
2013-01-05T13:45:54.593 Load timezone
2013-01-05T13:45:54.610 Exit Tf_main.FormCreate
2013-01-05T13:45:54.748 Create splash
2013-01-05T13:45:56.461 Show splash
2013-01-05T13:45:56.484 Create f_position
2013-01-05T13:45:56.508 Create f_search
2013-01-05T13:45:56.564 Create f_zoom
2013-01-05T13:45:56.569 Create f_getdss
2013-01-05T13:45:56.574 Loadlibrary libgetdss.so
2013-01-05T13:45:56.582 Library ok
2013-01-05T13:45:56.583 Create f_manualtelescope
2013-01-05T13:45:56.585 Create f_detail
2013-01-05T13:45:56.589 Create f_info
2013-01-05T13:45:56.611 Create f_calendar
2013-01-05T13:45:56.827 Create Tf_image
2013-01-05T13:45:56.833 Create f_printsetup
2013-01-05T13:45:56.852 Create f_print
2013-01-05T13:45:56.862 Main Init
2013-01-05T13:45:56.863 Enter Tf_main.Init
2013-01-05T13:45:56.863 SetDefault
2013-01-05T13:45:56.864 ReadDefault
2013-01-05T13:45:56.890 InitDS2000
2013-01-05T13:45:56.891 Create DB
2013-01-05T13:45:56.892 Background Image
2013-01-05T13:45:56.892 Constellation
2013-01-05T13:45:56.937 Connect DB
2013-01-05T13:45:56.949 DB connected
2013-01-05T13:45:56.958 Connected to the SQL database /root/.skychart/database/cdc.db
2013-01-05T13:45:56.959 Cursor
2013-01-05T13:45:56.997 Compass
2013-01-05T13:45:57.011 Starshape file
2013-01-05T13:45:57.012 Timezone
2013-01-05T13:45:57.472 Init calendar
2013-01-05T13:45:57.472 Create default chart
2013-01-05T13:45:57.537 Create new chart
2013-01-05T13:45:57.787 SkyChart : Init chart
2013-01-05T13:46:00.237 Chart Chart_1: Refresh
2013-01-05T13:46:00.238 Chart Chart_1: Get refresh lock
2013-01-05T13:46:00.239 Chart Chart_1: Init 508x338
2013-01-05T13:46:00.253 Chart Chart_1: Draw map
2013-01-05T13:46:00.254 SkyChart Chart_1: Full Refresh
2013-01-05T13:46:00.255 SkyChart Chart_1: Init
2013-01-05T13:46:00.256 SkyChart Chart_1: Init observatory
2013-01-05T13:46:00.257 SkyChart Chart_1: Init time
2013-01-05T13:46:00.257 SkyChart Chart_1: Init chart
2013-01-05T13:46:00.258 SkyChart Chart_1: Init coordinates
2013-01-05T13:46:00.262 Chart Chart_1: Release refresh lock
2013-01-05T13:46:00.267 Initialization error: Access violation
2013-01-05T13:46:02.613 Exit Tf_main.Init
2013-01-05T13:46:02.615 Application Run
2013-01-05T13:46:02.657 Chart_1 ChartResize
2013-01-05T13:46:02.664 Chart_1 ChartResize
2013-01-05T13:46:02.676 Enter Tf_main.FormShow
2013-01-05T13:46:02.762 Chart_1 ChartResize
2013-01-05T13:46:02.775 Chart_1 ChartResize
2013-01-05T13:46:02.786 Chart_1 ChartResize
2013-01-05T13:46:02.892 Chart_1 ChartResize
2013-01-05T13:46:02.918 Exit Tf_main.FormShow
2013-01-05T13:46:02.931 Chart_1 ChartResize
2013-01-05T13:46:03.112 Enter Tf_main.InitTimerTimer
2013-01-05T13:46:03.113 Exit Tf_main.InitTimerTimer
2013-01-05T13:46:03.234 ImageSetFocus
2013-01-05T13:46:03.480 Chart Chart_1: RefreshTimer
2013-01-05T13:46:03.480 Chart Chart_1: Refresh
2013-01-05T13:46:03.480 Chart Chart_1: Get refresh lock
2013-01-05T13:46:03.499 Chart Chart_1: Init 648x413
2013-01-05T13:46:03.501 Chart Chart_1: Draw map
2013-01-05T13:46:03.502 SkyChart Chart_1: Full Refresh
2013-01-05T13:46:03.503 SkyChart Chart_1: Init
2013-01-05T13:46:03.504 SkyChart Chart_1: Init observatory
2013-01-05T13:46:03.505 SkyChart Chart_1: Init time
2013-01-05T13:46:03.506 SkyChart Chart_1: Init chart
2013-01-05T13:46:03.507 SkyChart Chart_1: Init coordinates
2013-01-05T13:46:03.509 Chart Chart_1: Release refresh lock
TApplication.HandleException Access violation
  Stack trace:
  $410CEFFA
2013-01-05T13:46:04.401 Chart_1 Paint
2013-01-05T13:46:09.413 Exiting ...
2013-01-05T13:46:09.525 Destroy Tf_main
2013-01-05T13:46:09.529 Destroy Cursor
2013-01-05T13:46:09.530 Destroy end
2013-01-05T13:46:09.601 Destroy chart Chart_1
2013-01-05T13:46:09.656 End Destroy chart

(skychart:1528): Gdk-CRITICAL **: IA__gdk_cursor_unref: assertion `cursor->ref_count > 0' failed
root@rk3066dev:~# ^C

(0002400)
aruangra (reporter)
13-01-06 00:53

These are screenshots for Saturn and Jupiter.

http://imageshack.us/a/img585/1637/saturnw.jpg [^]
http://imageshack.us/a/img72/7237/jupiter.jpg [^]

The coordinates seems correct.
(0002401)
aruangra (reporter)
13-01-06 00:59
edited on: 13-01-06 01:00

I always get

2013-01-05T14:11:10.122 Ephemeris probably out of range, disabling any solar system object

when running a script:

root@rk3066dev:/home/pi/skychart/skychart/sample_client/perl# perl test3.pl
Name "main::path" used only once: possible typo at test3.pl line 12.
[Connected to 127.0.0.1:3292]
OK! id=1 chart=Chart_1
 We are connected as client 1 , the active chart is Chart_1
 Send CMD : search M42
2013-01-05T14:11:08.028 Ephemeris probably out of range, disabling any solar system object
2013-01-05T14:11:08.079 05h35m58.53s -05°22'40.4" C+N M 42 m: 4.00 Name:NGC 1976 sbr:11.00 Dim: 90.0 x 60.0 ' pa: 90 class:E+R 2 p nl desc:!!!;Theta Orionis and the great nebula M42;Trapezium* 6.7-7.7m;>50 var* invl;M 43 to NE Const:ORI
> Chart_1 : 05h35m58.53s -05°22'40.4" C+N M 42 m: 4.00 Name:NGC 1976 sbr:11.00 Dim: 90.0 x 60.0 ' pa: 90 class:E+R 2 p nl desc:!!!;Theta Orionis and the great nebula M42;Trapezium* 6.7-7.7m;>50 var* invl;M 43 to NE Const:ORI
Command success
 Send CMD : setfov 5d55m55s
Command success
 Send CMD : redraw
2013-01-05T14:11:10.122 Ephemeris probably out of range, disabling any solar system object
Command success
 Send CMD : saveimg PNG /home/pi/www/test.png
Command success
root@rk3066dev:/home/pi/skychart/skychart/sample_client/perl#

(0002403)
aruangra (reporter)
13-01-07 02:37
edited on: 13-01-07 02:54

Do I need to get some other files to test?
http://www.ephemeris.com/software.html [^]
ftp://ssd.jpl.nasa.gov/pub/eph/planets/ [^]

I think planets are at the right positions. What will this error affect?

(0002407)
Patrick Chevalley (administrator)
13-01-13 10:28

This is probably because the function result was not initialized by default to true with your processor.
Revision 2379 force the initialization so you not get this message:
http://sourceforge.net/p/skychart/code/2379/ [^]

You can install other files from ftp://ssd.jpl.nasa.gov/pub/eph/planets/ [^] , mainly if you want to compute the planet position for date in the past or future.
The default file is valid from 2000 to 2050.

- Issue History
Date Modified Username Field Change
13-01-05 14:27 aruangra New Issue
13-01-05 14:32 aruangra Note Added: 0002394
13-01-05 16:02 Patrick Chevalley Note Added: 0002396
13-01-05 16:02 Patrick Chevalley Assigned To => Patrick Chevalley
13-01-05 16:02 Patrick Chevalley Status new => confirmed
13-01-05 16:02 Patrick Chevalley Target Version => 3.8
13-01-05 16:02 Patrick Chevalley Summary Wrong plate coordinate => Wrong planet coordinate
13-01-06 00:35 aruangra Note Added: 0002399
13-01-06 00:36 aruangra Note Edited: 0002399 View Revisions
13-01-06 00:39 aruangra Note Edited: 0002399 View Revisions
13-01-06 00:53 aruangra Note Added: 0002400
13-01-06 00:59 aruangra Note Added: 0002401
13-01-06 01:00 aruangra Note Edited: 0002401 View Revisions
13-01-07 02:37 aruangra Note Added: 0002403
13-01-07 02:48 aruangra Note Edited: 0002403 View Revisions
13-01-07 02:48 aruangra Note Edited: 0002403 View Revisions
13-01-07 02:54 aruangra Note Edited: 0002403 View Revisions
13-01-07 02:54 aruangra Note Edited: 0002403 View Revisions
13-01-13 10:28 Patrick Chevalley Note Added: 0002407
13-01-13 10:28 Patrick Chevalley Status confirmed => resolved
13-01-13 10:28 Patrick Chevalley Resolution open => fixed
13-01-13 10:28 Patrick Chevalley Fixed in Version => 3.7 SVN
13-05-06 14:32 Patrick Chevalley Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker