View Issue Details

IDProjectCategoryView StatusLast Update
0001690SkyChart1-Softwarepublic17-03-31 12:35
ReporterSasaAssigned ToPatrick Chevalley 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSLubuntu 32-bitOS Version16.10
Product Version4.0 
Target Version4.2Fixed in Version4.1 SVN 
Summary0001690: Trouble using telescope
DescriptionCDC default settings. There is no real telescope to connecting with.

However, it is allowed to click on "Connect telescope" from main menu and open "Manual telescope" form with on top status. This further make quite problems...

This condition will prevent any further work with UI. For instance, if click further on main menu "Telescope settings", the form will be open and go to background immediately, making main form with on top status. Then only way to close the "Telescope settings" from is to move main form away of screen center, but be aware that that action will automatically switch second desktop on Lubuntu and split the form of the same application to different desktop screens...

Furthermore, if click on "Connect telescope" again, all apparently back in normal. If then again connect telescope and create new chart, all seems to block - main menu dos not open anymore and only Task manager is effective to kill all related skychart processes.

Is it possible to simplify behavior if use telescope? Using on top status on multiple forms in the same time makes real problem. I'm aware that using telescope should be restricted to active chart, however blocking forms and using on top status on more than one at the time apparently brings additional problems.

Perhaps to use similar as done with "Solar System Info" and link with correct chart?
TagsNo tags attached.

Relationships

related to 0001689 resolvedPatrick Chevalley Ciel 4.0-3575 Clock window not displaying correctly 

Activities

Patrick Chevalley

17-03-22 14:24

administrator   ~0003743

This look specific to LXDE, I can reproduce the problem using this desktop but using KDE it work normally.

Patrick Chevalley

17-03-31 12:35

administrator   ~0003754

Revision 3582 fix the Clock and Manual Telescope windows to make them in front of the chart on Windows and Mac, but not with Linux Gtk2.

Manual telescope must be on top of the chart, because to use it you click to a reference star, then to the object you want to go. It is very inconvenient if the telescope window is hidden in this process.
But because of this problem with Gtk2 I have to hide it.

The telescope window, manual or other, are linked to a single chart because you can connect more than one telescope, each to it's chart.

https://sourceforge.net/p/skychart/code/3582/

Issue History

Date Modified Username Field Change
17-03-21 15:38 Sasa New Issue
17-03-22 14:24 Patrick Chevalley Assigned To => Patrick Chevalley
17-03-22 14:24 Patrick Chevalley Status new => assigned
17-03-22 14:24 Patrick Chevalley Target Version => 4.2
17-03-22 14:24 Patrick Chevalley Note Added: 0003743
17-03-31 12:27 Patrick Chevalley Relationship added related to 0001689
17-03-31 12:35 Patrick Chevalley Note Added: 0003754
17-03-31 12:35 Patrick Chevalley Status assigned => resolved
17-03-31 12:35 Patrick Chevalley Resolution open => fixed
17-03-31 12:35 Patrick Chevalley Fixed in Version => 4.1 SVN