View Issue Details

IDProjectCategoryView StatusLast Update
0001735SkyChart1-Softwarepublic18-06-16 17:01
ReporterRolf StegelmannAssigned To 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionwon't fix 
PlatformMac (Intel)OSOS-XOS Version10.8.5
Product Version4.0 
Target VersionFixed in Version 
Summary0001735: LX200 Telescope connect does not support "cu" serial device
DescriptionIn The LX200 protocol setup for a Telescope. It asks for the serial device. It lists

/dev/tty.usbserial-A8004eor
/dev/cu.usbserial-A8004eor

It does not let me pick the cu.usbserial... device. I get a dialog that says:

Port /dev/cu.usbserial-A800eor cannot be opened!
 Not a typewriter.

followed with a dialog

Error opening LX200 on port /dev/cu.usbserial-a800eor
check if device is connected and power on.

It hangs when the "tty" port is specified.

This is because most telescope devices use only the three wire serial set up and don't assert the DTR signal. All other planetarium software I have worked with use the "cu" serial device port. This includes TheSkyX, Stellarium and Equinox Pro that I have worked with.

see web page for explanation:
https://lists.apple.com/archives/darwin-dev/2009/Nov/msg00099.html

In any case you should allow for both to be used. Those that have a DTR signal can use the tty and those without can use the cu. The work exactly the same except for not worrying about the DTR signal.


Steps To Reproduceselect LX200 protocol.
set the port on the connect to either tty or cu. The cu gets the "not a typewriter" dialog and the tty one hangs if the DTR is not asserted.

Additional InformationI am just evaluating this software to replace Equinox Pro, since it is no longer being maintained or available. Cartes Du Ciel looks promising so far. I like it better than theSkyX or Stellarium.

 
TagsLX200, serial

Activities

Patrick Chevalley

17-07-01 12:29

administrator   ~0003869

I have a lot of problem to maintain this direct driver because I no more use a LX200 myself.

The program is now optimized to run with INDI drivers on Mac and Linux, and ASCOM on Windows.

Any reason you not use INDI with your LX200?
Indiserver is very easy to use on Mac: http://www.cloudmakers.eu/indiserver/

For the next version I clearly mark this LX200 and the Encoders direct drivers as obsolete to prevent new users to use them.

I let this issue open if someone with a Mac and a LX200 want to fix it.

Rolf Stegelmann

17-07-01 20:36

reporter   ~0003870

I'm just evaluating the program and have not looked at INDI implementations. I have not needed them as of yet. I'll take a look at adding INDI to my Mac. A while ago INDI was not ready for prime time on the Mac. I will take another look at it.

Rolf Stegelmann

17-07-02 03:08

reporter   ~0003871

I tried the cloudmaker version of INDI. It works perfectly and it can't be easier to install. Thanks!

Patrick Chevalley

17-07-02 11:37

administrator   ~0003873

Thank you to confirm it work.

I will update the documentation to remove the INDI compilation instruction and let only this link to Cloudmakers.

They have other nice software for OS X that are worth to look at.

Kal Krishnan

17-07-26 07:45

reporter   ~0003929

I am sorry to say that I cannot get my Meade LX200 (classic model) to work either with the direct connection (due to the aforementioned cu.usbserial problem), nor with the INDI driver. With the INDI driver, if I bring up the GUI, it seems to say it connects fine (see attached screenshot), but, when I go the Telescope Connect dialog, I only see the Telescope Simulator as an option. Clicking on "Refresh" either does nothing, or sometimes just crashes SkyChart software.

The same arrangement is working fine with Stellarium (with their direct drivers). I would urge you to enable the cu.usbserial port, if that is possible. Thanks.

Patrick Chevalley

17-07-26 10:03

administrator   ~0003931

Last edited: 17-07-26 10:05

View 2 revisions

Kal,
This issue is very specific to the way OS X set the serial port and I cannot fix it without a Mac and a LX200 for testing.
If a developer with the require hardware want to fix it I will be happy to apply is patch.

For INDI, do you add the LX200 driver to the Indiserver? click the + button after you start Indiserver to get a list of driver. (and the - button to remove the simulator)

Kal Krishnan

17-07-26 18:12

reporter   ~0003935

Hi Patrick, thanks for the reply. Did you see the screenshot I uploaded? Yes, I did add the LX200 to INDI, as shown in that screenshot. Also, SkyChart's own INDI control panel shows (also seen in the screenshot) that it can see the LX200. However, the "Connect to Scope" dialog does not show the scope and only shows the simulator.

This seems to be an INDI driver bug in SkyCharts. Can you please take a look?

Patrick Chevalley

17-07-26 19:16

administrator   ~0003936

Sorry, I miss the screenshot.

You cannot select the driver from the "Connect to Scope" dialog, you must open the menu Telescope/Telescope settings... first.
Here select INDI and click the button "Connect and get device list". After is finish select the telescope name from the list.
See : https://www.ap-i.net/skychart/start?id=en/documentation/system#indi_driver

Kal Krishnan

17-07-26 19:21

reporter   ~0003937

Yes, I meant to say "Connect and get device list". When I click on that button, nothing shows up other than the Telescope Simulator.

Patrick Chevalley

17-07-26 20:15

administrator   ~0003938

Which version do you use?

It may be necessary to use the last beta version because of this bug: 0001741

Rolf Stegelmann

17-07-26 20:30

reporter   ~0003939

Last edited: 17-07-27 00:40

View 2 revisions

@Kal: I ran it, and my list shows the simulator and the LX200 Basic, and it connects. My connect list shows the simulator and the LX200 Basic. Sometimes the "Connect and get device list" takes a little bit of time to update. Try it more than once. I don't have an LX200 but I use software that translates the LX200 protocol.

by the way I am using the INDI server from cloudmakers because it is a no nonsense installation. Just drop the app into the applications folder and start it.
see attachment INDIgui
http://www.cloudmakers.eu/indiserver/

Edited to take out the bad command comment. This seems to be a dropped serial character issue on OS-X 10.12.6. It seems two work fine on OS-X 10.8.5. Since my send chain is kind of long it could be anywhere. I will keep it to myself for now. Send chain is skychart->INDIserver->IOGear402 serial to wifi -> wifi to serial into com1 port on pc -> LX200 protocol translate to ASCOM -> telescope driver and back the other way.



INDIgui.png (99,084 bytes)
INDIgui.png (99,084 bytes)

Kal Krishnan

17-07-27 18:32

reporter   ~0003942

Last edited: 17-07-27 18:36

View 2 revisions

@Rolf: I have only used the Cloudmakers version. Didn't even know there was an alternative!

@Patrick: I tried the beta version last night, and it does appear to be somewhat better in the sense that I was able to get it to work 2 times (out of about 20 attempts). So, at least I know it CAN work!

There seems to be a race between the timeout, and how long it takes to connect. It takes SO long to connect (as mentioned by @Rolf) that most of the times it times out, but once in a while it succeeds. This long delay is true for both the "get device list" call, and the subsequent "Connect" call.

If I look at the Cloudmakers INDI window, it shows "1 Client" as soon as the connection attempt is made, but SkyCharts still shows that it is connecting, and times out eventually. Then the INDI window shows "no clients".

So, my questions are:

1. Why the LOOONG delay to establish connection on a local TCP port? Is this something that can be fixed?
2. Can the timeout be set longer (for test purposes) to test my theory that it times out before it succeeds?

One other really weird fact (I almost don't want to mention it, it is so goofy, but just in case it gives you a clue, I mention it!): Both the times that it actually succeeded in connecting, I was attempting to make a Screen Video recording (using Quicktime Screen capture) to show you how it doesn't work. But, when I try a couple of times, with the video recorder going, it worked! Maybe just co-incidence, or maybe the Video recorder slowed the system down, or something. Like I said, this is quite goofy, feel free to ignore if it makes no sense.

I just saw @Rolf's comment on send chain, so I wanted to add that my send chain is as simple as can be: SkyChart -> INDI -> USB Serial port -> an actual LX200.
Thanks,
-Kal.

Patrick Chevalley

18-06-16 17:01

administrator   ~0004789

I remove the native lx200 driver for the next version.

If you still have problem with Indi please report the problem in the Indi forum.

Issue History

Date Modified Username Field Change
17-06-30 23:25 Rolf Stegelmann New Issue
17-06-30 23:25 Rolf Stegelmann Tag Attached: LX200
17-06-30 23:25 Rolf Stegelmann Tag Attached: serial
17-07-01 12:29 Patrick Chevalley Status new => acknowledged
17-07-01 12:29 Patrick Chevalley Note Added: 0003869
17-07-01 20:36 Rolf Stegelmann Note Added: 0003870
17-07-02 03:08 Rolf Stegelmann Note Added: 0003871
17-07-02 11:37 Patrick Chevalley Note Added: 0003873
17-07-26 07:45 Kal Krishnan File Added: Screen Shot 2017-07-25 at 10.38.02 PM.png
17-07-26 07:45 Kal Krishnan Note Added: 0003929
17-07-26 10:03 Patrick Chevalley Note Added: 0003931
17-07-26 10:05 Patrick Chevalley Note Edited: 0003931 View Revisions
17-07-26 18:12 Kal Krishnan Note Added: 0003935
17-07-26 19:16 Patrick Chevalley Note Added: 0003936
17-07-26 19:21 Kal Krishnan Note Added: 0003937
17-07-26 20:15 Patrick Chevalley Note Added: 0003938
17-07-26 20:30 Rolf Stegelmann File Added: INDIgui.png
17-07-26 20:30 Rolf Stegelmann Note Added: 0003939
17-07-27 00:40 Rolf Stegelmann Note Edited: 0003939 View Revisions
17-07-27 18:32 Kal Krishnan Note Added: 0003942
17-07-27 18:36 Kal Krishnan Note Edited: 0003942 View Revisions
18-06-16 17:01 Patrick Chevalley Status acknowledged => resolved
18-06-16 17:01 Patrick Chevalley Resolution open => won't fix
18-06-16 17:01 Patrick Chevalley Note Added: 0004789