User Tools

Site Tools


Sidebar


News:


Cartes du Ciel is free software released under the terms of the
GNU banner GNU General Public License


Hosted by SourceForge.net

Support This Project


en:documentation:system

General

General

In this window, you can manage the SkyChart database. It contains the orbital elements of comets and asteroids, SAC picture information, information about the DSS/RealSky pictures and information of observatory locations.
In order to display comets and asteroids, SkyChart needs to calculate the ephemeris, and store them in a database. But before SkyChart can do that, you need to download fresh files with orbital elements for comets and asteroids. See the comet and asteroid tabs from the Setup → Solar System dialog box.

You may also want to create the SAC pictures information database. For more about installing and downloading SAC pictures, see the Object tab from the Configuration → Pictures dialog box.
The information about countries and the detailed information of Observatory locations are also stored in a database. You can create them by Configuration → Observatory.






A standard SkyChart installation creates a SQLite database. SQLite is very fast and for everyone simple to use. Use SQLite. Maybe you have reason to choose MySQL as DBMS. For example, maybe you wish to search comet and asteroid data external from Skychart, with other applications. Or you want to share one single database with many computers. You need to have at least basic knowledge about MySQL to do your queries. Another warning: When you decide to load the data from MPCORB without any limitation into your MySQL DBMS, it can take some hours. If you use Windows XP, copy the file libmySQL.dll from the bin directory of your MySQL installation to the installation directory of Skychart.

  • SQLite: an input area contains the path to SQLite DB. With Windows XP, it is stored in \My documents\[user]\Local Settings\Skychart\database\. You can specify an alternate location.


  • MySQL: You need a MySQL server to connect to. A local server connection is proposed, which works fine with a MySQL local server installation. You can specify an alternate connection with default parameters:
    • DB Name cdc
    • Host Name localhost
    • Userid root
    • Password [your mysql root passwd]
    • Port 3306 (standard MySQL port)
    • Asteroid Setting directs yous to Configuration → Solar System → Asteroid. (older SkyChart versions)
    • Comet Setting directs you to Configuration → Solar System → Comet. (older SkyChart versions)
    • Drop DataBase this button deletes all database content.
  • Create DataBase button launches the SQL “define tables” script.
  • Check lets you verify if the tables succesfully are created.

Directory group specifies the SkyChart installation path and personal (Your_Documents\Carte du Ciel\) data path. You can specify alternate locations for a non standard installation. Help yourself with the directory icon at right of the input area.

Server


Here you can set connection parameters to use Skychart as a server. You can verify the connection states in View → Server information

  • SkyChart accepts connections by checking Use TCP/IP Server.
  • SkyChart verifies the attendance of the client and closes the connection if the client is not active by checking Client Connection Keep Alive.
  • Server IP interface define the network interface Skychart is listening on. The default 127.0.0.1 allow only for local connection. If the client is remote, you need to set your interface IP address or 0.0.0.0 to listen on all the interfaces.
  • SkyChart is listening on the port set in Server IP Port, if you change this, you must change client software correspondingly.

Telescope



From the menu: Setup → System → Telescope

Before you can use SkyChart to work with your telescope, you need to do some basic settings here. First, select which interface driver you will use. Depending on your choice, the content of the dialog box changes. You can choose from:

ASCOM

Use this on Windows only. With ASCOM you can drive most astronomical equipment like your mount and dome. If you don't have the Ascom driver installed, you can download it from http://ascom-standards.org/

Indi driver

Use this on Linux or Mac only. The Indi package is designed to use with all sorts of astronomical devices. Many computer operated mounts and domes can be driven by Indi. You can download this driver if it didn't come with your Linux distribution. When you want to use the Indi driver, make your specific settings in the dialog.

After setting the server host and port, click “Connect and get device list” to fill the list of driver supported by your INDI server. Then select the telescope driver from the list.

It may be difficult to know the device serial port name if you have many adapter or if you use a USB-serial adapter. In this case use the dmesg command to find this name.
In the following example you must indicate /dev/ttyS0 for the motherboard port or /dev/ttyUSB0 for the USB port.

serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
usb 5-1: FTDI USB Serial Device converter now attached to ttyUSB0

LX200

You have to activate the “obsolete drivers” to show this option.

This driver supports LX200, Autostar, Magellan I/II and other systems using the LX200 protocol. When you are using Mel Bartels' stepper motor system to drive your mount, you can use this driver.

On the main bar, you will find the telescope group icons. After you made the proper basic settings for your computer operated telescopes, you need to configure the your driver by a click on the icon to drive your telescope in the right way.
You need the and icons from the main bar to synchronize your mount with an object on the chart or to slew it to another object. See for more information about this the menu Telescope.

Encoder

You have to activate the “obsolete drivers” to show this option.

You can use this with an encoder box using Tangent protocols like the Ouranos, AAM or NGC-MAX.

Manual Mount

When you use this, SkyChart asks you to give the settings for your specific mount. Choose your mount type from Equatorial Mount or Alt/Az Mount. Next, you set how many full turns you must make on your knob to slew your mount by one degree of arc. Usually, manual mounts are wormgear driven. Most common is a mount with 144 tooths on the worm wheel for both directions. When you know the number of tooths, calculation of the number of turns per degree of arc, or per hour is easy:
Per degree: 144 / 360 = 0.4
Per hour: 144 / 24 = 6
Also you need the find out how to make the direction setttings for the knobs. Only when a counter-clockwise turn of a knob causes an increase in the right ascension, azimuth, declination, or altitude, you need to check the appropriate Reverse .. Direction. Otherwise, leave it unchecked. From now on, you can find instructions how to turn the knobs of your mount to move from one object to another. To find these, first click the object on the chart to which your telescope is pointed. Next, click on the object you want to observe. Now click on the label to retrieve the information details. The last lines show you who to turn the knobs on your mount.

Language


Simply select the language from the combo box that you want SkyChart to use.

If your language isn't there, why not make your own GUI translation? It 's not hard, only takes a few hours. Have look here.

SAMP


Set the default options for the SAMP interface.

  • Try to auto-connect : Connect automatically to a running SAMP hub when the program start.
  • Receive coordinates : Allow the program to jump to coordinates received from other applications. For example a click in Aladin.
  • Receive FITS images : Allow the program to receive an image from other applications. From Aladin use the menu “Interop / Broadcast selected image to…”
  • Receive VO table data : Allow the program to receive data table from other applications. From Aladin use the menu “Interop / Broadcast selected table to…”.

You can request a confirmation before to accept any data and keep the data you receive for offline use. The default is to cleanup the data when the SAMP connection is closed.

It is also possible to send data from Skychart to the other applications.

  • To connect to a hub after the program is started, or to get the connection status, use the menu File -> SAMP.
  • To send coordinates use the right click menu SAMP send coordinates
  • You can send table data from the VO catalog setup.
  • To send a FITS image use the right click menu Image list, the “Send image” button.
en/documentation/system.txt · Last modified: 2017/07/02 11:52 by pch