User Tools

Site Tools


en:documentation:flat_frame

Flat frame

When using the image stacking option it can be useful to process the individual frames with a flat before stacking.
This is specially interesting when using star alignment because this preclude the use of a flat later in the processing.

Use the menu File → Flat frame → Apply to current image if you want to divide the currently displayed image with the flat.
You can identify an image that was divided by a flat with a comment at the end of the FITS header.

Information

This menu show information about the current flat frame, the size of the image and the mean level.

You have two options to define the flat frame, using the camera directly or using a processed flat frame. The second option is preferred because the processed flat as less noise.

Create from the camera

Procedure:

  1. Camera should be connected and cooling on if available.
  2. Set the required binning in Preview tool. Use the same binning used for stacking.
  3. Select the same exposure time to get a mean level about 2/3 of the camera range.
  4. Use your flat panel or other way to take flat.
  5. Select menu File → Flat frame → Create from camera
  6. Click Continue. A flat will be taken and saved for future use.

Load a flat file

Select menu File → Flat frame → Load flat file

Select the flat file from the file dialog.

The file must be taken with the same binning than used for stacking. This file must use a pixel format of 16bit.

Clear flat frame

To remove/clear the flat frame select the menu File → Flat frame → Clear Flat frame

Check the flat frame

Take a preview image, select the menu File → Flat frame → Apply to current image
Verify the vignetting and dust are removed and the processing do not create unwanted artifact.

en/documentation/flat_frame.txt · Last modified: 2022/11/26 14:55 by pch